hduoj1016,Prime Ring Problem,dfs题,重点

Prime Ring Problem

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.





Input
n (0 < n < 20).
 
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 
Sample Input
6
8
 
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

分析:
深搜题,用一个数组存储一个数是否被用过。并且由于题目特点判断质数不必用通常的方法,省下一点时间。

code:
#include<iostream>
#include<cstdio>
#include<cmath>
#define MAX_SIZE 20
using namespace std;
int a[MAX_SIZE+5],n;
int use[MAX_SIZE+5];
const int prime[11]={3,5,7,11,13,17,19,23,29,31,37};
bool belong(int n)
{
    for(int i=0;i<11;i++)
        if(prime[i]==n) return true;
    return false;
}
void dfs(int r)
{
    int i;
    if(r==n&&belong(1+a[r-1]))//判断第一个数与最后一个数是否和为质数
    {
        printf("%d",a[0]);
        for(i=1;i<n;i++)
            printf(" %d",a[i]);
        printf("\n");
        return;
    }
    for(i=2;i<=n;i++)
        if(use[i]==0&&belong(i+a[r-1]))
        {
            use[i]=1;
            a[r]=i;
            dfs(r+1);
            use[i]=0;
        }
    return;
}
int main()
{
    int time=0;
    while(scanf("%d",&n)==1)
    {
        time++;
        memset(use,0,sizeof(use));
        a[0]=1;
        use[0]=1;
        printf("Case %d:\n",time);
        if(n%2==0) dfs(1);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值