POJ1426,Find The Multiple,bfs...注意类型 5兆内存过了...

7 篇文章 0 订阅

Find The Multiple

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

分析:

STL的queue还是很好用的,开始考虑用位运算移位的方法来生成下一个数,这样就涉及到同一个数在二进制和十进制下的转换,增加了代码量。

用类似递推的方法考虑的话,每一个数,在结尾添一个0或添一个1能生成两个数。不难看出这样也能生成所有满足条件的数,可能顺序会有点奇怪。

但根据题意,不许要保证得出的结果是不是最小的,这样以上的分析足够保证程序的正确性了。


code:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
using namespace std;
int n;
void bfs()
{
    queue<long long> q;
    while(!q.empty())
        q.pop();
    q.push(1);
    while(1)
    {
        long long tmp=q.front();
        if(tmp%n==0)
        {
            cout<<tmp<<'\n';
            return;
        }
        q.pop();
        q.push(tmp*10);
        q.push(tmp*10+1);
    }
}
int main()
{
    while(scanf("%d",&n),n)
        bfs();
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值