1009. Product of Polynomials (25)

1009. Product of Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6

/* 
输入:两行数据表示两个多项式,K表示K个系数非零的项,N1表示指数,An1表示系数,以此类推 
输出:A和B两个多项式的乘积,输出格式与输入同,保留一位小数。
注意:数组要开的够大。 
*/
#include<iostream>
#include<string.h>
#include<stdio.h>
#include<iomanip>
using namespace std;
int main()
{
	double a[1050],b[1050],sum[2050];
	int k;
	int max1=0,max2=0,nonzero=0;
	memset(a,0,sizeof(a));
	memset(b,0,sizeof(b));
	memset(sum,0,sizeof(sum));
	cin>>k;
	while(k--)
	{
		int n;
		double an;
		cin>>n>>an;
		a[n]=an;
		if(n>max1)max1=n;
	} 
	cin>>k;
	while(k--)
	{
		int n;
		double an;
		cin>>n>>an;
		b[n]=an;
		if(n>max2)max2=n;
	} 
	for(int i=0;i<=max1;i++)
	{
		for(int j=0;j<=max2;j++)
		{
			sum[i+j]+=(a[i]*b[j]);
		}
	}
	for(int i=0;i<=(max1+max2);i++)
	{
		if(sum[i]!=0.0)nonzero++;
	}
	cout<<nonzero;
	for(int i=(max1+max2);i>=0;i--)
	{
		if(sum[i]!=0.0)
		{
			cout<<" "<<i;  
            cout<<fixed<<setprecision(1);  
            cout<<" "<<sum[i];  
		}
	}
	cout<<endl;
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值