POJ3294-Life Forms(后缀数组)

POJ3294-Life Forms(后缀数组)

You may have wondered why most extraterrestrial life forms resemble humans, differing by superficial traits such as height, colour, wrinkles, ears, eyebrows and the like. A few bear no human resemblance; these typically have geometric or amorphous shapes like cubes, oil slicks or clouds of dust.

The answer is given in the 146th episode of Star Trek - The Next Generation, titled The Chase. It turns out that in the vast majority of the quadrant’s life forms ended up with a large fragment of common DNA.

Given the DNA sequences of several life forms represented as strings of letters, you are to find the longest substring that is shared by more than half of them.

Input
Standard input contains several test cases. Each test case begins with 1 ≤ n ≤ 100, the number of life forms. n lines follow; each contains a string of lower case letters representing the DNA sequence of a life form. Each DNA sequence contains at least one and not more than 1000 letters. A line containing 0 follows the last test case.

Output
For each test case, output the longest string or strings shared by more than half of the life forms. If there are many, output all of them in alphabetical order. If there is no solution with at least one letter, output “?”. Leave an empty line between test cases.

Sample Input
3
abcdefg
bcdefgh
cdefghi
3
xxx
yyy
zzz
0
Sample Output
bcdefg
cdefgh

?

题意:
找出出现在多于n/2个字符串中的最长子串

求出后缀数组,二分答案,然后吧height数组以k分组,看在不同串出现次数是否多于n/2

AC代码:

#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cstdio>
#include<cstring>
#include<vector>
#include<cmath>
#include<complex>
#include<queue>
#include <map>
#define T 111111
using namespace std;
char s[T];
int a[105];
int t1[T],t2[T],cc[T],x[T],sa[T],rank[T],height[T];
int len;
int vis[105];
map<int,int> mp;
bool cmp(int *y,int a,int b,int k)
{
    int a1=y[a];
    int b1=y[b];
    int a2=a+k>=len ? -1:y[a+k];
    int b2=b+k>=len ? -1:y[b+k];
    return a1==b1 && a2==b2;
}
int make_sa()
{
    int *x=t1,*y=t2;
    int m=255;
    for(int i=0; i<m; i++) cc[i]=0;
    for(int i=0; i<len; i++) ++cc[x[i]=s[i]];
    for(int i=1; i<m; i++) cc[i]+=cc[i-1];
    for(int i=len-1; i>=0; i--) sa[--cc[x[i]]]=i;

    for(int k=1; k<=len; k<<=1)
    {
        int p=0;
        for(int i=len-k; i<len; i++) y[p++]=i;
        for(int i=0; i<len; i++)
           if( sa[i]>=k ) y[p++]=sa[i]-k;

        for(int i=0; i<m; i++) cc[i]=0;
        for(int i=0; i<len; i++) ++cc[x[y[i]]];
        for(int i=1; i<m; i++) cc[i]+=cc[i-1];
        for(int i=len-1; i>=0; i--) sa[--cc[x[y[i]]]]=y[i];

        swap(x,y);
        m=1; x[sa[0]]=0;
        for(int i=1; i<len; i++)
          x[sa[i]]=cmp(y,sa[i],sa[i-1],k) ? m-1:m++;

        if( m>=len ) break;
    }
}
void make_height()
{
    for(int i=0; i<len; i++) rank[sa[i]]=i;
    height[0]=0;
    int k=0;
    for(int i=0; i<len; i++)
    {
        if(!rank[i]) continue;
        int j=sa[rank[i]-1];
        if(k) k--;
        while(s[i+k]==s[j+k]) k++;
        height[rank[i]]=k;
    }
}
bool check(int k,int n)
{
    int sum=1,flag=0;
    memset(vis,0,sizeof(vis));
    for(int i=0;i<len;i++){
        int z=sa[i];
        map<int,int>::iterator itea;
        itea=mp.lower_bound(z);
        int y=itea->second;
        int lst=itea->first;
        if(height[i]<k||s[sa[i]]=='$'||sa[i]+k>lst){
            sum=1;
            memset(vis,0,sizeof(vis));
            vis[y]++;
            continue;
        }
        if(!vis[y]){
            vis[y]++;
            sum++;
        }
        if(sum>n/2) return true;
    }
    return false;
}
void print(int k,int n)
{
    int sum=1,flag=0;
    memset(vis,0,sizeof(vis));
    for(int i=0;i<len;i++){
        int z=sa[i];
        map<int,int>::iterator itea;
        itea=mp.lower_bound(z);
        int y=itea->second;
        int lst=itea->first;
        if(height[i]<k||s[sa[i]]=='$'||sa[i]+k>lst){
            sum=1;
            memset(vis,0,sizeof(vis));
            vis[y]++;
            continue;
        }
        if(!vis[y]){
            vis[y]++;
            sum++;
        }
        if(sum>n/2){
            for(int j=0;j<k;j++){
                printf("%c",s[sa[i]+j]);
            }
            printf("\n");
            for(i;height[i]>=k&&i<len;i++);
            i--;
        }
    }
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF&&n)
    {
        int m=0,maxn=0;
        mp.clear();
        for(int i=0;i<n;i++){
            scanf("%s",s+m);
            int y=strlen(s+m);
            maxn=max(maxn,y);
            s[m+y]='$';
            m+=y+1;
            mp[m-1]=i;
        }
        len=m-1;
        s[m]='\0';
        make_sa();
        make_height();
        int l=0,r=maxn+1;
        while(l!=r){
            int mid=(l+r)/2;
            if(check(mid,n)) l=mid+1;
            else r=mid;
        }
        if(r-1){
            print(r-1,n);
        }
        else printf("?\n");
        cout<<"\n";
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值