浙大PTA 树的遍历

树的遍历

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:
输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:
在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
4 1 6 3 5 7 2
题意:给你后序遍历序列和中序遍历序列,求层序遍历序列
思路:根据后序遍历序列和中序遍历序列建树,对树进行层序遍历

#include <iostream>
#include<queue>
using namespace std;

int post[35] = {0}, in[35] = {0};
typedef struct TNode * PtrToTNode;
struct TNode{
    int Data;
    PtrToTNode Left, Right;
};
typedef PtrToTNode Tree;

Tree BulidTree(int postL, int inL, int n);
void LevelorderTraversal(Tree T);

int main()
{
    int n;
    scanf("%d", &n);
    for(int i = 0; i < n; i++)
        scanf("%d", &post[i]);
    for(int i = 0; i < n; i++)
        scanf("%d", &in[i]);
    Tree T = (Tree)malloc(sizeof(struct TNode));
    T = BulidTree(0, 0, n);
    LevelorderTraversal(T);
    return 0;
}

Tree BulidTree(int postL, int inL, int n)
{
    /*
    postL:后序遍历起始位置
    inL:中序遍历起始位置
    n:节点个数
    */
    if(n == 0){ return NULL;}       /*长度为0,树为空*/
    int root = post[postL + n - 1]; /*后序遍历的最后一个节点为根*/
    Tree T;
    T = (PtrToTNode)malloc(sizeof(struct TNode));
    T->Data = root;
    int i;
    for( i = 0; i < n; i++)
        if(in[inL + i] == root)break;   /*找到根的位置*/
    int L = i, R = n - L - 1;           /*左子树节点数为L,右子树节点数为R*/
    T->Left = BulidTree(postL, inL, L); /*建立左子树*/
    T->Right = BulidTree(postL + L, inL + L + 1, R);/*建立右子树*/
    return T;
}

void LevelorderTraversal(Tree T)
{
    bool flag = true;
    if(!T)
        return;
    else{
        queue<Tree>q;
        q.push(T);
        while(!q.empty()){
            Tree tmp = q.front();
            if(flag){flag = false;}
            else
                printf(" ");
            printf("%d", tmp->Data);
            q.pop();
            if(tmp->Left)
                q.push(tmp->Left);
            if(tmp->Right)
                q.push(tmp->Right);
        }
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值