HDU - 2609 How many

How many

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5865 Accepted Submission(s): 2751

Problem Description
Give you n ( n < 10000) necklaces ,the length of necklace will not large than 100,tell me
How many kinds of necklaces total have.(if two necklaces can equal by rotating ,we say the two necklaces are some).
For example 0110 express a necklace, you can rotate it. 0110 -> 1100 -> 1001 -> 0011->0110.

Input
The input contains multiple test cases.
Each test case include: first one integers n. (2<=n<=10000)
Next n lines follow. Each line has a equal length character string. (string only include ‘0’,‘1’).

Output
For each test case output a integer , how many different necklaces.

Sample Input
4
0110
1100
1001
0011
4
1010
0101
1000
0001

Sample Output
1
2

Author
yifenfei

Source
奋斗的年代

板子题:套一个字符串的最小表示法 的板子,构造最小字符串,然后用set去重,最后得到的set.size()即要求的答案。

#include <iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<set>
using namespace std;

const int maxn = 1e4 + 100;

int minString(string s)
{
    int i = 0, j = 1, k = 0;
    int len = s.size();
    while(i < len && j < len && k < len)
    {
        if(s[(i + k) % len] == s[(j + k) % len])
            k++;
        else
        {
            if(s[(i + k) % len] > s[(j + k) % len])
                i = i + k + 1;
            else
                j = j + k + 1;
            if(i == j)
                j++;
            k = 0;
        }
    }
    return i < j ? i : j;
}

string s[maxn];
string s2[maxn];
int visited[maxn];
int main()
{
    int n;
    while(~scanf("%d", &n))
    {
        for(int i = 0; i < n; i++)
        {
            cin>>s[i];
        }
        int len = s[0].size();
        set<string>myset;
        for(int i = 0; i < n; i++){
            int index = minString(s[i]);
            string str = s[i].substr(index, len - index) + s[i].substr(0,index);
//            cout<<str<<endl;
            myset.insert(str);
        }
        cout<<myset.size()<<endl;
    }



    return 0;
}
/*
ababab
ba
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值