1073 Scientific Notation (20分)

测试地址:

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9].[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros.

Sample Input 1:

+1.23400E-03

Sample Output 1:

0.00123400

Sample Input 2:

-1.2E+10

Sample Output 2:

-12000000000

题意:

给出以科学计数法的格式输入的数字A,要求输出普通数字表示法的 A,并保证所有有效位都被保留,包括末尾的0

思路1:

在输入时分开输入,符号位用字符输入,数字部分存储在数组 a 里,E后面的进位数字单独存储,记为ed,之后按进位数字的正负分开讨论。

当 ed<0 时,表示小数点向左移动,先输出“ 0. ”,之后输出 (-ed)-1 个0,之后输出数组 a 中的所有数字;

当 ed>0 时,表示小数点向右移动,此前字符数组 a 中全部初始化为 0,故循环条件就为  (i<ed+1 || a[i]!=0),如果 i==ed+1 时,需要补一个小数点,a[i]!=0 是为了输出 a 剩余的没有输出的字符。

c++代码1:

#include<cstdio>
int main(){
	char head, a[10010]={0};
	int ed;
	scanf("%c%c.%[0-9]E%d", &head, &a[0], a+1, &ed);
	if(head == '-')	printf("-");
	if(ed < 0){
		printf("0.");
		for(int i = 1; i < (-ed); i++)
			printf("0");
		printf("%s", a);
	}
	else{
		for(int i = 0; i<ed+1 || a[i]!=0; i++){
			if(i == ed+1)	printf(".");
			printf("%c", a[i]==0 ? '0' : a[i]);
		}
	}
	return 0;
}

思路2:

直接用 string 字符输入,之后用 substr 函数将输入的字符分割开,之后按 E 后面进位数字的正负进行讨论。

n 保存 E 后面的字符串所对应的数字,t 保存 E 前面的字符串,不包括符号位。当 n<0 时表示向前移动,那么先输出0,然后输出 abs(n)-1 个 0,然后继续输出 t 中的所有数字;当 n>0 时候表示向后移动,那 么先输出第一个字符,然后将 t 中尽可能输出 n 个字符,如果 t 已经输出到后一个字符 (j == t.length()) 那 么就在后面补 n-cnt 个0,否则就补充一个小数点。 然后继续输出 t 剩余的没有输出的字符

c++代码2:

#include<iostream> 
using namespace std; 
int main() {    
	string s;    
	cin >> s;    
	int i = 0;    
	while (s[i] != 'E') i++;    
	string t = s.substr(1, i-1);    
	int n = stoi(s.substr(i+1));    
	if (s[0] == '-') cout << "-";    
	if (n < 0) {        
		cout << "0.";        
		for (int j = 0; j < abs(n) - 1; j++) 
			cout << '0';        
		for (int j = 0; j < t.length(); j++)
		    if (t[j] != '.') 
				cout << t[j];    
	} 
	else {        
		cout << t[0];        
		int cnt, j;        
		for (j = 2, cnt = 0; j < t.length() && cnt < n; j++, cnt++) 
			cout << t[j];        
			if (j == t.length()) {            
				for (int k = 0; k < n - cnt; k++) 
					cout << '0';        
			} 
			else {            
				cout << '.';            
				for (int k = j; k < t.length(); k++) 
					cout << t[k];        
			}    
		}    
		return 0;
	}

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值