1083 List Grades (25分)

测试地址:

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output NONE instead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:

NONE

【题意】

给出 n 个学生的信息,包括 姓名、id、成绩

最后一行输入两个成绩 grade1,grade2

输出成绩在 grade1 和 grade2 之间的学生的姓名和 id,并按成绩从高到低排序;如果没有,输出 NONE

【思路】

设置结构体存储学生信息,按成绩高低进行排序即可;(It is guaranteed that all the grades are distinct.所有学生的成绩都不相同)

标记一下是否有满足条件的学生,如果没有,输出 “NONE”。

【AC代码】

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
typedef struct{
	string name, id;
	int grade;
}num;
int cmp(num a, num b){
	return a.grade > b.grade;
}
int main(){
	int n, grade1, grade2, flag=0;
	cin >> n;
	vector<num> v(n);
	for(int i = 0; i < n; i++){
		cin >> v[i].name >> v[i].id >> v[i].grade;
	}
	cin >> grade1 >> grade2;
	sort(v.begin(), v.end(), cmp);
	for(int i = 0; i < n; i++){
		if(v[i].grade>=grade1 && v[i].grade<=grade2){
			cout << v[i].name << " " << v[i].id << endl;
			flag = 1;
		}
	}
	if(!flag){
		cout << "NONE";
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值