1083 List Grades (25分)【结构体排序】

1083 List Grades (25分)

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output NONE instead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:

NONE

题目大意:

给出n个考生的姓名学号及分数,将这些信息按分数由高到低进行排序,并输出给定区间的考生信息,如果不存在满足条件的考生,则输出NONE。注意所有考生的分数不同。 

解题思路:

结构体排序,注意这道题的所有考生的分数均不同,因此非常简单的结构体排序即可。

#include<iostream>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;

struct student {
	string name;
	string id;
	int score;
}stu[110];

int cmp(student a, student b)
{
	return a.score > b.score;
}

int main()
{
	int n, l, h;
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		cin >> stu[i].name >> stu[i].id >> stu[i].score;
	}
	cin >> l >> h;
	sort(stu, stu + n, cmp);
	int flag = 0;
	for (int i = 0; i < n; i++)
	{
		if (stu[i].score <= h&&stu[i].score >= l)
		{
			flag = 1;
			cout << stu[i].name << " " << stu[i].id << endl;
		}
	}
	if (flag == 0)
		cout << "NONE" << endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值