7-9 最长对称子串 (25 分)

7-9 最长对称子串 (25 分)
对给定的字符串,本题要求你输出最长对称子串的长度。例如,给定Is PAT&TAP symmetric?,最长对称子串为s PAT&TAP s,于是你应该输出11。

输入格式:
输入在一行中给出长度不超过1000的非空字符串。

输出格式:
在一行中输出最长对称子串的长度。

输入样例:
Is PAT&TAP symmetric?
输出样例:
11
存在一个超时问题 代码处有注释

#include<iostream>
#include<set>
#include<algorithm>
#include<stdio.h>
using namespace std;
int main(){
string s;
int max=1;
string a="",b="",c="",a1="",b1="",c1="";
getline(cin,s);
int l=s.size();
for(int i=0;i<l;i++){
	for(int j=l;j>i;j--)//i<l  关键 
	{
 		b=a=s.substr(i,j);
	reverse(a.begin(),a.end());
	if(b==a){
		if(max<a.size()){
			max=a.size();
		}
	}	
	}
}
cout<<max;
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值