PTA-06-图2 Saving James Bond - Easy Version

该问题描述了詹姆斯·邦德如何在一个充满鳄鱼的湖中逃脱的情景。他需要从中央岛屿跳到鳄鱼头上,判断在给定最大跳跃距离下能否成功逃到岸边。输入包含鳄鱼数量和最大跳跃距离,以及每个鳄鱼的位置坐标。输出是根据能否逃脱的结果打印'Yes'或'No'。提供的示例显示在某些情况下,如第一个案例,詹姆斯可以逃脱,而在其他情况下,如第二个案例,他无法逃脱。
摘要由CSDN通过智能技术生成

题目描述

This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line “Yes” if James can escape, or “No” if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No


#include<cstdio>
#include<iostream>
#include<cmath>
#include<queue>
using namespace std;
#define MaxVertex 105


const double diameter=15.0;

struct Node{//存鳄鱼的信息
    int hor;//x
    int ver;//y
    bool visit;//是否被访问
    bool safe;//是否能上岸
    bool jump;//是否一步跳上
};

bool isSafe;
int N;//点个数==鳄鱼数量
int D;//跳跃距离
struct Node G[MaxVertex];

//计算两点距离
double get_len(int x1,int y1,int x2,int y2)
{
    return sqrt(pow(x1-x2,2.0)+pow(y1-y2,2.0));
}

//计算该点能否到达岸边
bool ashore(int x,int y)
{
    if(abs(x-50)<=D||abs(y-50)<=D||abs(x+50)<=D||abs(y+50)<=D) return true;
    else return false;
}
//确认该点是否能够上岸
void get_safe()
{
    for(int i=0;i<N;i++){
        if(ashore((G[i].hor),(G[i].ver))) G[i].safe=true;
        else G[i].safe=false;
    }
}
//在中心 确认哪些点可以一步跳上去 
void get_jump()
{
    for(int i=0;i<N;i++){
        if(get_len(G[i].hor,G[i].ver,0,0)<=D+diameter/2) G[i].jump=true;
        else G[i].jump=false;
    }
}

//初始化
void Init()
{
    cin>>N>>D;
    int x,y;
    for(int i=0;i<N;i++){
        cin>>x>>y;
        G[i].hor=x;
        G[i].ver=y;
        G[i].visit=false;
    }

    get_safe();
    get_jump();
    isSafe=false;
}

void bsf(int n)
{
    queue<Node> q;
    struct Node tmp;
    G[n].visit=true;
    q.push(G[n]);
    while(!q.empty()){
        tmp=q.front();
        q.pop();
        if(tmp.safe){
            isSafe=true;
            return;
        }
        for(int i=0;i<N;i++){
            if(get_len(tmp.hor,tmp.ver,G[i].hor,G[i].ver)<=D&&!G[i].visit){
                G[i].visit=true;
                q.push(G[i]);
            }
        }
    }
}
//遍历所有一步能跳到的鳄鱼
void listCompoent()
{
    for(int i=0;i<N;i++){
        if(G[i].jump){
            bsf(i);
        }
    }
    if(isSafe) cout<<"Yes"<<endl;
    else cout<<"No"<<endl;
}
int main()
{
    Init();
    listCompoent();
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值