poj1154 连通分量 简单深搜

60 篇文章 0 订阅

LETTERS
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8031 Accepted: 3625

Description

A single-player game is played on a rectangular board divided in R rows and C columns. There is a single uppercase letter (A-Z) written in every position in the board. 
Before the begging of the game there is a figure in the upper-left corner of the board (first row, first column). In every move, a player can move the figure to the one of the adjacent positions (up, down,left or right). Only constraint is that a figure cannot visit a position marked with the same letter twice. 
The goal of the game is to play as many moves as possible. 
Write a program that will calculate the maximal number of positions in the board the figure can visit in a single game.

Input

The first line of the input contains two integers R and C, separated by a single blank character, 1 <= R, S <= 20. 
The following R lines contain S characters each. Each line represents one row in the board.

Output

The first and only line of the output should contain the maximal number of position in the board the figure can visit.

Sample Input

3 6
HFDFFB
AJHGDH
DGAGEH

Sample Output

6


题意很简单:就是在一个矩形的字符阵中寻找一个没有重复的的字符的字符序列,方向只有四个方向,求这个序列字符个数


解题思路:从每一个位置开始搜索一下,在每一个位置递归进去,运用回溯就可以满足了

然后实现代码,其实很简单,可以和我的另外一篇blog对比一下http://blog.csdn.net/summer__show_/article/details/51146603

都是连通分量求最大值

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int R,C;
char visit[25][25];
int temp[100];
int dx[]={0,0,1,-1};
int dy[]={1,-1,0,0};
int ans,coun;

int dfs(int x,int y)
{
    for(int i=0;i<4;i++){
        int tempx=x+dx[i];
        int tempy=y+dy[i];
        if(tempx>=0&&tempy>=0&&tempx<R&&tempy<C&&temp[visit[tempx][tempy]]==0){
            temp[visit[tempx][tempy]]=1;
            coun++;
            dfs(tempx,tempy);
            ans=max(ans,coun);

            temp[visit[tempx][tempy]]=0;//回溯
            coun--;
        }
    }
}

int main()
{
    while(scanf("%d%d",&R,&C)!=EOF)
    {
        getchar();
        for(int i=0;i<R;i++)
            scanf("%s",visit[i]);
        memset(temp,0,sizeof(temp));

        ans=coun=1;
        temp[visit[0][0]]=1;
        dfs(0,0);

        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值