poj 2367 topo 排序

Genealogical tree
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4582 Accepted: 3033 Special Judge

Description

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

Output

The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

Sample Input

5
0
4 5 1 0
1 0
5 3 0
3 0

Sample Output

2 4 5 3 1


题意:

4  5  1  0   第二行,表示 4 5 1 和数字  2  (第二行)有关联         以  0   结束输入

1  0            第三行,表示 1        和数字  3  (第三行)有关联        以  0   结束输入

............



通过下面这个和代码中的解释理解topo排序







#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define mem(a) memset(a,0,sizeof(a))

int map[105][105];
int indegree[105];
int ans[105];
int n;

void topo_sort()
{
    int pos;
    for(int i=1;i<=n;i++){
//------------搜索入度为 0 第一个点------------//
        for(int j=1;j<=n;j++)
            if(indegree[j]==0){
                pos=j;
                break;
            }
//---------记录每一个入度为0的点---------------//
        indegree[pos]=-1;
        ans[i]=pos;
//-------点pos指向的点都减少入度--------------//
        for(int j=1;j<=n;j++)
            if(map[pos][j])
                indegree[j]--;
    }
}
//--------------------------------------------//
int main()
{
    //freopen("in.txt","r",stdin);
    int t;
    scanf("%d",&n);
    mem(map);
    mem(indegree);
//-----------记录 t 的入度-------------------//
    for(int i=1;i<=n;i++){
        while(scanf("%d",&t),t){
            map[i][t]=1;
            indegree[t]++;
        }
    }
//------------------------------------------//
    topo_sort();

    printf("%d",ans[1]);
    for(int i=2;i<=n;i++)
        printf(" %d",ans[i]);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值