poj 1273 最大流之最短路径增广法(EK)

60 篇文章 0 订阅

Drainage Ditches
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 71182 Accepted: 27694

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50


题意:

给定一套排水系统,编号 1   N为源点和汇点

一共有N个交汇点,M条排水沟

给定相应两点间排水沟排水的速度,求最大的排水速率

题解:

构图很简单,使用EK模板

模板很容易理解就不多说了


#include<queue>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

#define MAXN 210

int m,n;
int a[MAXN][MAXN],flow[MAXN][MAXN];
int vis[MAXN],pre[MAXN];

int EK()
{
    int ans=0;
    int qu[MAXN],qs,qe;
    while(1)
    {
        memset(vis,0,sizeof(vis));
        qu[qs=1]=1,qe=2;
        vis[qs]=0x3f3f3f3f;
        while(qs<qe)
        {
            int start=qu[qs++];
            for(int i=1;i<=n;i++){
                if(!vis[i]&&(a[start][i]>flow[start][i])){
                    vis[i]=min(vis[start],a[start][i]-flow[start][i]);
                    pre[i]=start,qu[qe++]=i;
                }
            }
        }
        if(!vis[n])
            break;

        for(int i=n;i!=1;i=pre[i]){
            flow[pre[i]][i]+=vis[n];
            flow[i][pre[i]]-=vis[n];
        }
        ans+=vis[n];
    }
    return ans;
}

int main()
{
    int u,v,c;
    //freopen("in.txt","r",stdin);
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        memset(a,0,sizeof(a));
        memset(flow,0,sizeof(flow));
        for(int i=0;i<m;i++){
            scanf("%d%d%d",&u,&v,&c);
            a[u][v]+=c;
        }
        printf("%d\n",EK());
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值