2014年北京区域赛 hdu 5037 贪心

Frog

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 3675    Accepted Submission(s): 918


Problem Description
Once upon a time, there is a little frog called Matt. One day, he came to a river.

The river could be considered as an axis.Matt is standing on the left bank now (at position 0). He wants to cross the river, reach the right bank (at position M). But Matt could only jump for at most L units, for example from 0 to L.

As the God of Nature, you must save this poor frog.There are N rocks lying in the river initially. The size of the rock is negligible. So it can be indicated by a point in the axis. Matt can jump to or from a rock as well as the bank.

You don't want to make the things that easy. So you will put some new rocks into the river such that Matt could jump over the river in maximal steps.And you don't care the number of rocks you add since you are the God.

Note that Matt is so clever that he always choose the optimal way after you put down all the rocks.
 

Input
The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains N, M, L (0<=N<=2*10^5,1<=M<=10^9, 1<=L<=10^9).

And in the following N lines, each line contains one integer within (0, M) indicating the position of rock.
 

Output
For each test case, just output one line “Case #x: y", where x is the case number (starting from 1) and y is the maximal number of steps Matt should jump.
 

Sample Input
  
  
2 1 10 5 5 2 10 3 3 6
 

Sample Output
  
  
Case #1: 2 Case #2: 4


题意:

一只青蛙一步最多可以跳 L 长

(0,m)原本有 n 个石头,你是上帝,你可以在里面任意放石头

但是青蛙很聪明,每一次都选择最优的一块石头跳

问上帝你,青蛙最多跳多少次(因为上帝的使坏)

题解:贪心

注意:石头给出的序号不一定是升序





#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

#define MAXN 200005
int a[MAXN];

int cmp(const void *a,const void *b)
{
    return *(int *)a-*(int *)b;
}

int main()
{
    int T;
    int cases=1;
    int n,m,k;
    //freopen("in.txt","r",stdin);
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&k);
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        a[0]=0,a[++n]=m;
        qsort(a,n,sizeof(a[0]),cmp);

        int cnt=0;
        int last=k;//上一步跳的距离
        for(int i=1;i<=n;i++){
            int x=(a[i]-a[i-1])%(k+1);
            int y=(a[i]-a[i-1])/(k+1);
            if(last+x>=k+1){//判断是否可以和上一段合并(要选择最优解)
                last=x;
                cnt+=y*2+1;
            }
            else{
                last+=x;
                cnt+=y*2;
            }
        }
        printf("Case #%d: %d\n",cases++,cnt);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值