Lightoj 1027 期望

You are in a maze; seeing n doors in front of you in beginning. You can choose any door you like. The probability for choosing a door is equal for all doors.

If you choose the ith door, it can either take you back to the same position where you begun in xi minutes, or can take you out of the maze after xi minutes. If you come back to the same position, you can't remember anything. So, every time you come to the beginning position, you have no past experience.

Now you want to find the expected time to get out of the maze.


Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer n (1 ≤ n ≤ 100) denoting the number of doors. The next line contains n space separated integers. If the ith integer (xi) is positive, you can assume that the ith door will take you out of maze after xi minutes. If it's negative, then the ith door will take you back to the beginning position after abs(xi) minutes. You can safely assume that 1 ≤ abs(xi) ≤ 10000.

Output

For each case, print the case number and the expected time to get out of the maze. If it's impossible to get out of the maze, print 'inf'. Print the result in p/q format. Where p is the numerator of the result and q is the denominator of the result and they are relatively prime. See the samples for details.

Sample Input

3

 

1

1

 

2

-10 -3

 

3

3 -6 -9

Sample Output

Case 1: 1/1

Case 2: inf

Case 3: 18/1



题意:

你身在一个迷宫里面,现在在你面前有N个门。每个门要么把你传送出迷宫,要么把你传送到原来的位置且你的记忆也会回到初始的时候。现在给出每个门传送的时间t,若t为正数,说明该门花费时间t可以将你传送出迷宫,若 t 为负数,说明该门花费时间 t 将你传送到原来的位置。已知你选择每个门的概率是相同的,问你出迷宫所花费时间的期望。输出结果写出分数形式,且分子分母互质,若不能出迷宫输出inf

题解:

对于每个门不管是出去还是回来,去这个门的时间期望都是1/n*(相应的时间)

但是如果回来了那么就是1/n*(时间+E)

因为你利用了这个门,但是你回来了,你还是想出去的话,那么出去的那么就是走这个门的概率乘以接下来出去的期望

然而我们发现其实期望是一样的

对于第三个样例

E=1/n*(3) + 1/n*(6+E) + 1/n*(9+E)

那么总的式子就是

E=1/n*(sum1)+1/n*(sum2+door2*E)

sum1是出去的门的总和,sum2是回来的门的时间绝对值的总和

解方程得到E,分目不为零即可


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int gcd(int a,int b)
{
    while(b)
    {
        int t=a%b;
        a=b;
        b=t;
    }
    return a;
}

int main()
{
    int temp,T,cases=1;
    int n,dr1,dr2,sum1,sum2;
    //freopen("in.txt","r",stdin);
    scanf("%d",&T);
    while(T--)
    {
        dr1=dr2=0;
        sum1=sum2=0;
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%d",&temp);
            if(temp>0){
                dr1++;
                sum1+=temp;
            }
            else{
                dr2++;
                sum2-=temp;
            }
        }

        int up=sum1+sum2;
        int down=n-dr2;
        int t=gcd(up,down);
        up/=t;
        down/=t;
        if(n==dr2)
            printf("Case %d: inf\n",cases++);
        else
            printf("Case %d: %d/%d\n",cases++,up,down);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值