hdu 6045 简单的思维题 2017 Multi-University Training Contest - Team 2

Is Derek lying?

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 408    Accepted Submission(s): 245


Problem Description
Derek and Alfia are good friends. Derek is Chinese,and Alfia is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of N choice questions and each question is followed by three choices marked “ A ” “ B ” and “ C ”.Each question has only one correct answer and each question is worth 1 point.It means that if your answer for this question is right,you can get 1 point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell Derek the total score of him and Alfia .Then Alfia will ask Derek the total score of her and he will tell her: “My total score is X ,your total score is Y .”But Derek is naughty,sometimes he may lie to her. Here give you the answer that Derek and Alfia made,you should judge whether Derek is lying.If there exists a set of standard answer satisfy the total score that Derek said,you can consider he is not lying,otherwise he is lying.
 

Input
The first line consists of an integer T ,represents the number of test cases.

For each test case,there will be three lines.

The first line consists of three integers N , X , Y ,the meaning is mentioned above.

The second line consists of N characters,each character is “ A ” “ B ” or “ C ”,which represents the answer of Derek for each question.

The third line consists of N characters,the same form as the second line,which represents the answer of Alfia for each question.

Data Range: 1N80000 , 0X,YN, Ti=1N300000
 

Output
For each test case,the output will be only a line.

Please print “ Lying ” if you can make sure that Derek is lying,otherwise please print “ Not lying ”.
 

Sample Input
  
  
2 3 1 3 AAA ABC 5 5 0 ABCBC ACBCB
 

Sample Output
  
  
Not lying Lying
 

Source


题意:

有n个选择题,选项有A B C ,两个人分别写出自己的答案,答对一题得一分

第一个人得了x分,第二个人得了y分,判断这个数据是否是错的

题解:

见代码中的注释


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

#define MAXN 300005
char s1[MAXN];
char s2[MAXN];

int main()
{
    int T;
    int n,x,y;
    freopen("in.txt","r",stdin);
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&x,&y);
        scanf("%s",s1);
        scanf("%s",s2);
        int cnt=0;
        for(int i=0;i<n;i++)
            if(s1[i]==s2[i])
                cnt++;

        int flag=0;
        int num=min(cnt,min(y,x));
        ///例如cnt=3  x=1.y=3的时候,我们假设cnt都是对的
        ///但是x却没有那么大,所以我们要假设这三个数里面最小的是cnt个题目里面有min个正确的
        ///然后两个人对的数量和减去相同的里面对的数量的和
        ///得到不相同的答案里面对的数量和,必须要小于等于n-cnt
        if(x+y-2*num<=n-cnt)
            flag=1;

        puts(flag?"Not lying":"Lying");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值