LightOJ - 1245 Harmonic Number (II) 分块加速

LightOJ - 1245 Harmonic Number (II) 分块加速
一、 题目
Description
I was trying to solve problem ‘1234 - Harmonic Number’, I wrote the following code

long long H( int n ) {
    long long res = 0;
    for( int i = 1; i <= n; i++ )
        res = res + n / i;
    return res;
}

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.

Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n < 231).

Output
For each case, print the case number and H(n) calculated by the code.

Sample Input
11
1
2
3
4
5
6
7
8
9
10
2147483647
Sample Output
Case 1: 1
Case 2: 3
Case 3: 5
Case 4: 8
Case 5: 10
Case 6: 14
Case 7: 16
Case 8: 20
Case 9: 23
Case 10: 27
Case 11: 46475828386
二、 题目大意
ni=1ni ,其中n<2^31。
三、 解题思路
分块计算,对于i-n/(n/i)区间,n/i的值相同,将该区间一同计算可以加速运算。
四、 代码实现

#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
#include<list>
#include<algorithm>
#include<vector>
#include<cmath>
#include<string>
#include<fstream>
//#pragma comment(linker,"/STACK:1024000000,1024000000")
using namespace std;
const int N=1e6+5;
bool vis[10000005];
int prime[700005];
int n;
int main()
{
    int t,tt=0;
    scanf("%d",&t);
    while(t--)
    {
      scanf("%d",&n);
      long  long ans=0;
      long long j;
      for(long long i=1;i<=n;i=j+1)
      {
          j=n/(n/i);
          ans+=(long long)(j-i+1)*(n/i);
      }
      printf("Case %d: %lld\n",++tt,ans);
    }
   return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值