练习系统 实验二 All in All

当前编程题:实验二 进制转换问题(16级) ---All in All

5.
问题描述
You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.
Given two strings s and t, you have to decide whether s is a subsequence of t,i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.
输入形式
The input contains several test cases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by white space. The length of s and t will no more than 100000.
输出形式
For each test case output "Yes", if s is a subsequence of t,otherwise output "No".
样例输入
4
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter
样例输出
Yes
No
Yes
No

说实话这个编的真是很顺哈哈大笑


#include<stdio.h>
#include<string.h>


void handle(char aa[],char bb[])
{
int i,j,flag=0,k=0;
for(i=0;i<strlen(aa);i++)
{
for(j=k;j<strlen(bb);j++)
{
if(aa[i]==bb[j])
    {
  aa[i]='0';
  bb[j]='1';
  k=j;
  }
}
}
for(i=0;i<strlen(aa);i++)
{
if(aa[i]!='0')
{
flag=1;
}
}
if(flag==1)
{
printf("No\n");
}
else
{
printf("Yes\n");
}
}




int main()
{
char aa[1000],bb[1000];
int i,n;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%s%s",aa,bb);
handle(aa,bb);
}
return 0;
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值