CF1005A Tanya and Stairways

 

题目描述

Little girl Tanya climbs the stairs inside a multi-storey building. Every time Tanya climbs a stairway, she starts counting steps from 1 1 1 to the number of steps in this stairway. She speaks every number aloud. For example, if she climbs two stairways, the first of which contains 3 3 3 steps, and the second contains 4 4 4 steps, she will pronounce the numbers 1,2,3,1,2,3,4 1, 2, 3, 1, 2, 3, 4 1,2,3,1,2,3,4 .

You are given all the numbers pronounced by Tanya. How many stairways did she climb? Also, output the number of steps in each stairway.

The given sequence will be a valid sequence that Tanya could have pronounced when climbing one or more stairways.

输入输出格式

输入格式:

 

The first line contains n n n ( 1≤n≤1000 1 \le n \le 1000 1≤n≤1000 ) — the total number of numbers pronounced by Tanya.

The second line contains integers a1,a2,…,an a_1, a_2, \dots, a_n a1​,a2​,…,an​ ( 1≤ai≤1000 1 \le a_i \le 1000 1≤ai​≤1000 ) — all the numbers Tanya pronounced while climbing the stairs, in order from the first to the last pronounced number. Passing a stairway with x x x steps, she will pronounce the numbers 1,2,…,x 1, 2, \dots, x 1,2,…,x in that order.

The given sequence will be a valid sequence that Tanya could have pronounced when climbing one or more stairways.

 

输出格式:

 

In the first line, output t t t — the number of stairways that Tanya climbed. In the second line, output t t t numbers — the number of steps in each stairway she climbed. Write the numbers in the correct order of passage of the stairways.

 

输入输出样例

输入样例#1: 复制

7
1 2 3 1 2 3 4

输出样例#1: 复制

2
3 4 

输入样例#2: 复制

4
1 1 1 1

输出样例#2: 复制

4
1 1 1 1 

输入样例#3: 复制

5
1 2 3 4 5

输出样例#3: 复制

1
5 

输入样例#4: 复制

5
1 2 1 2 1

输出样例#4: 复制

3
2 2 1 

 

很简单,上代码:

#include<cstdio>
using namespace std;
int a[1000],b[1000];
int n,temp,j=0,ans=0;
int main()
{

        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&temp);
             a[temp]++;
             if(temp!=1)
             {
                 b[j]++;

             }
             if(temp==1)
                j++;
        }
        printf("%d\n",a[1]);
        for(int i=1;i<=j;i++)
            printf("%d ",(b[i]+1));
        return 0;

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

不会敲代码的小帅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值