poj 2262 Goldbach's Conjecture【质数和】

Goldbach's Conjecture

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 48895 Accepted: 18617

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 

Every even number greater than 4 can be 
written as the sum of two odd prime numbers.


For example: 

8 = 3 + 5. Both 3 and 5 are odd prime numbers. 
20 = 3 + 17 = 7 + 13. 
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.


Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 
Each test case consists of one even integer n with 6 <= n < 1000000. 
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

题意:输入n,n=a+b,a,b都为素数,输出|a-b|最大的一组解,若不存在则输出一句话

思路:让下标为素数的数组值为0,通过判断isprime【a】==0&&isprime[n-a]==0输出结果

代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<iostream>
using namespace  std;
const int maxn=1000008;
long long isprime[maxn];
void prime()///令是是素素数的为0,排除法,筛选素数
{
    long long i,j;
    for(i=2; i<=maxn; i++)
    {
        if(!(isprime[i]))
        {
            isprime[i]=0;
        }
        for(j=i*2; j<=maxn; j+=i)
        {
            isprime[j]=1;///素数的倍数都不是素数
        }
    }
}
int main()
{
   long long n;
   prime();
   while(scanf("%lld",&n)!=EOF)
   {
       if(n==0)
       break;
       int t=0;
      for(long long i=2;i<=n;i++)
      {
          if(isprime[i]==0&&isprime[n-i]==0)
          {
            printf("%lld = %lld + %lld\n",n,i,n-i);
            t=1;
            break;
          }
       }
     if(t==0) printf("Goldbach's conjecture is wrong.\n");
   }
   return 0;
}






 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

不会敲代码的小帅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值