poj 2356 Find a multiple 鸽【鸽巢原理】

 

Find a multiple

Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 9054

 

Accepted: 3883

 

Special Judge

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order. 

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3

Source

题意:在给出的n个数中,找出连续的m个数,使m个数相加的和是n的 整数倍,若存在不止一种情况,则输出任意一种,若不存在则输出0.(此题必有解,0的情况不存在)

证明:令sum【i】为前i项和,则sun【i】%n的结果在【1,n-1】之间,有sum[i]%n有n个结果,由抽屉原理可知必有两个余数相同,即sum【j]%n=sum[i]%n,则此两项sum【】相减的结果必为n的倍数,下标为j+1~i的数为所求结果

代码: 

#include<cstdio>
#include<iostream>
#include<string>
using namespace std;
int sum[10008],mod[10008];
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        int temp;
        scanf("%d",&temp);
        sum[i]=sum[i-1]+temp;
    }
    for(int i=1;i<=n;i++)
    {
        if(sum[i]%n==0)
        {
            printf("%d\n",i);
            for(int j=1;j<=i;j++)
            {
                printf("%d\n",sum[j]-sum[j-1]);
            }
            break;
        }
        if(mod[sum[i]%n]!=0)
        {
            int  j=mod[sum[i]%n]+1;
            printf("%d\n",i-j+1);
            for(;j<=i;j++)
            {
                printf("%d\n",sum[j]-sum[j-1]);
            }
           break;
        }
        mod[sum[i]%n]=i;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

不会敲代码的小帅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值