题目描述
The cows are having a picnic! Each of Farmer John's K (1 ≤ K ≤ 100) cows is grazing in one of N (1 ≤ N ≤ 1,000) pastures, conveniently numbered 1...N. The pastures are connected by M (1 ≤ M ≤ 10,000) one-way paths (no path connects a pasture to itself).
The cows want to gather in the same pasture for their picnic, but (because of the one-way paths) some cows may only be able to get to some pastures. Help the cows out by figuring out how many pastures are reachable by all cows, and hence are possible picnic locations.
K(1≤K≤100)只奶牛分散在N(1≤N≤1000)个牧场.现在她们要集中起来进餐.牧场之间有M(1≤M≤10000)条有向路连接,而且不存在起点和终点相同的有向路.她们进餐的地点必须是所有奶牛都可到达的地方.那么,有多少这样的牧场呢?
输入输出格式
输入格式:
Line 1: Three space-separated integers, respectively: K, N, and M
Lines 2..K+1: Line i+1 contains a single integer (1..N) which is the number of the pasture in which cow i is grazing.
Lines K+2..M+K+1: Each line contains two space-separated integers, respectively A and B (both 1..N and A != B), representing a one-way path from pasture A to pasture B.
输出格式:
Line 1: The single integer that is the number of pastures that are reachable by all cows via the one-way paths.
输入输出样例
输入样例#1: 复制
2 4 4
2
3
1 2
1 4
2 3
3 4
输出样例#1: 复制
2
说明
The cows can meet in pastures 3 or 4.
题意:在一个有向无权图中查找每个牛都能到达的牧场个数
思路:dfs遍历每个牛可到达的牧场mk【i】++,若最终的mk【i】==k(牛的个数),说明每个牛都可以到达,ans++(符合题意的牧场数),通过二位数组保存通往的牧场
代码:
#include<cstdio>
#include<vector>
#include<iostream>
#include<cstring>
using namespace std;
int loca[1008],visit[1008],mk[1008];
int k,n,m,ans=0;
int b[1008][1008];
void dfs(int x)
{
mk[x]++;visit[x]=1;
for(int i=1;i<=n;i++)
{
if(!visit[b[x][i]])
{
dfs(b[x][i]);
}
}
}
int main()
{
scanf("%d%d%d",&k,&n,&m);
for(int i=1;i<=k;i++)
{
scanf("%d",&loca[i]);
}
for(int i=1;i<=m;i++)
{
int x,y;
scanf("%d%d",&x,&y);
b[x][y]=y;
}
for(int i=1;i<=k;i++)
{
memset(visit,0,sizeof(visit));
dfs(loca[i]);
}
for(int i=1;i<=n;i++)
{
if(mk[i]==k)
{
ans++;
}
}
printf("%d\n",ans);
return 0;
}