hdu 2838 Cow Sorting (树状数组+逆序对变形)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2838

Problem Description

Sherlock's N (1 ≤ N ≤ 100,000) cows are lined up to be milked in the evening. Each cow has a unique "grumpiness" level in the range 1...100,000. Since grumpy cows are more likely to damage Sherlock's milking equipment, Sherlock would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes Sherlock a total of X + Y units of time to exchange two cows whose grumpiness levels are X and Y.

Please help Sherlock calculate the minimal time required to reorder the cows.

 

 

Input

Line 1: A single integer: N
Lines 2..N + 1: Each line contains a single integer: line i + 1 describes the grumpiness of cow i.

 

 

Output

Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.

 

 

Sample Input

 

3 2 3 1

 

 

Sample Output

 
7

Hint

Input Details Three cows are standing in line with respective grumpiness levels 2, 3, and 1. Output Details 2 3 1 : Initial order. 2 1 3 : After interchanging cows with grumpiness 3 and 1 (time=1+3=4). 1 2 3 : After interchanging cows with grumpiness 1 and 2 (time=2+1=3).

 

题意:给定一个序列,相邻的数可相互交换,但以两数的和作为代价。计算使此序列为升序时,最小的代价。

分析:当前位置的x的代价为前面比其的数的和再加上次数向前移动t次乘x即为最下的代价。在上面一题求交换次数的基础上面,定义一个结构体增加一个变量求出前面比当前位置大的数的和即可。(也可以通过两个数组实现)

代码:

#include<cstdio>
#include<cstring>
using namespace std;
#define LL long long
const int N=100008;
struct node
{
    LL num;
    LL val;
}c[N];

void add(LL x,LL y,LL num)
{
    for(;x<=N;x+=(x&(-x)))
    {
        c[x].val+=y;
        c[x].num+=num;
    }
}
LL num_sum(LL  x)
{
    LL  ans=0;
    for(;x;x-=(x&(-x)))
    {
        ans+=c[x].num;
    }
    return ans;
}
LL val_sum(LL  x)
{
     LL  ans=0;
    for(;x;x-=(x&(-x)))
    {
        ans+=c[x].val;
    }
    return ans;
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
      LL ans=0;
      memset(c,0,sizeof(c));
      for(int i=1;i<=n;i++)
      {
        LL  x;
        scanf("%lld",&x);
        add(x,x,1);
        int time=i-num_sum(x);
        ans+=(LL)(time*x+val_sum(n)-val_sum(x));
      }
      printf("%lld\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

不会敲代码的小帅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值