HDU 2838 Cow Sorting【树状数组+逆序数】

Sherlock’s N (1 ≤ N ≤ 100,000) cows are lined up to be milked in the evening. Each cow has a unique “grumpiness” level in the range 1…100,000. Since grumpy cows are more likely to damage Sherlock’s milking equipment, Sherlock would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes Sherlock a total of X + Y units of time to exchange two cows whose grumpiness levels are X and Y.
Please help Sherlock calculate the minimal time required to reorder the cows.
Input
Line 1: A single integer: N
Lines 2..N + 1: Each line contains a single integer: line i + 1 describes the grumpiness of cow i.
Output
Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.
Sample Input
3
2
3
1
Sample Output
7

Hint
Input Details
Three cows are standing in line with respective grumpiness levels 2, 3, and 1.
Output Details
2 3 1 : Initial order.
2 1 3 : After interchanging cows with grumpiness 3 and 1 (time=1+3=4).
1 2 3 : After interchanging cows with grumpiness 1 and 2 (time=2+1=3).

题意:给你一个n个数的序列,求逆序数对的和;
分析:用树状数组去维护动态求和的过程,主要是插入位置和排序后位置的来回切换;

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;

const int MAXN = 100000 + 10;
LL n;

struct node {
    LL cnt;
    LL sum;
}s[MAXN];

LL lowbit(LL x) {
    return x & (-x);
}

inline void update(LL i, LL val, LL x) {
    while(i <= n) {
        s[i].cnt += x;
        s[i].sum += val;
        i += lowbit(i);
    }
}

inline LL query_cnt(LL x) {
    LL sum = 0;
    while(x > 0) {
        sum += s[x].cnt;
        x -= lowbit(x);
    }
    return sum;
}

inline LL query_sum(LL x) {
    LL ans = 0;
    while(x > 0) {
        ans += s[x].sum;
        x -= lowbit(x);
    }
    return ans;
}

int main() {
    while(~scanf("%lld", &n)) {
        memset(s, 0, sizeof(s));
        LL ans = 0, ant = 0, x;
        for(LL i = 1; i <= n; ++i) {
            scanf("%lld", &x);
            update(x, x, 1LL);
            LL tt1 = x - query_cnt(x);
            LL res1 = tt1 * x + (x * (x - 1) / 2) - query_sum(x - 1);
            ant += res1;
//          LL tt = i - query_cnt(x); //两种写法都可以 
//          LL res = tt * x + query_sum(n) - query_sum(x);
//          ans += res;
        }
        printf("%lld\n", ant);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值