LightOJ--1094-- Farthest Nodes in a Tree(树的直径裸题)【模板】

Given a tree (a connected graph with no cycles), you have to find the farthest nodes in the tree. The edges of the tree are weighted and undirected. That means you have to find two nodes in the tree whose distance is maximum amongst all nodes.

Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with an integer n (2 ≤ n ≤ 30000) denoting the total number of nodes in the tree. The nodes are numbered from 0 to n-1. Each of the next n-1 lines will contain three integers u v w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 10000)denoting that node u and v are connected by an edge whose weight is w. You can assume that the input will form a valid tree.

Output

For each case, print the case number and the maximum distance.

Sample Input

2

4

0 1 20

1 2 30

2 3 50

5

0 2 20

2 1 10

0 3 29

0 4 50

Sample Output

Case 1: 100

Case 2: 80

题意:

        查找树上任意两点间的最大距离。

分析:

        两次BFS或着DFS基于可以了。(证明:http://www.cnblogs.com/wuyiqi/archive/2012/04/08/2437424.html

代码:

    之前用的模板太low,从网站上找了一个粘上。

#include<stdio.h>
#include<iostream>
#include<queue>
#include<string.h>
#include<algorithm>
using namespace std;
#define MAXN 30000+10
#define MAXM 900000+10
#define INF 0x3f3f3f
int n,cnt,head[MAXN],vis[MAXN],dis[MAXN];
int ans,sx;
struct node
{
	int u,v;
	int val,next;
}edge[MAXM];
void add(int u,int v,int val)
{
	node E={u,v,val,head[u]};
	edge[cnt]=E;
	head[u]=cnt++;
}
void bfs(int x)
{
	queue<int>q;
	ans=0;
	memset(vis,0,sizeof(vis));
	memset(dis,0,sizeof(dis));
	q.push(x);
	vis[x]=1;
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		for(int i=head[u];i!=-1;i=edge[i].next)
		{
			node E=edge[i];
			if(!vis[E.v]&&dis[E.v]<dis[u]+E.val)
			{
				vis[E.v]=1;
				dis[E.v]=dis[u]+E.val;
				q.push(E.v);
				if(dis[E.v]>ans)
				{
					ans=dis[E.v];
					sx=E.v;
				}
			}
		}
	}
}
int main()
{
	int t;
	int k=1;
	cin>>t;
	while(t--)
	{
		cin>>n;
		cnt=0;
		memset(head,-1,sizeof(head));
		int a,b,c;
		for(int i=1;i<n;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			a++,b++;
			add(a,b,c);
			add(b,a,c);
		}
		sx=1;
		bfs(1);
		bfs(sx);
		printf("Case %d: %d\n",k++,ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

不会敲代码的小帅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值