-
描述
-
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.-
输入
- Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99. 输出
- Your program is to write to standard output. The highest sum is written as an integer. 样例输入
-
5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
样例输出
-
30
一道经典的动态规划问题【外号:我的第一道动态规划!】
#include <cstdio>
int a[105][105];
int b[105][105];
int maxn(int a, int b)
{
return a > b ? a : b;
}
int main()
{
int n;
while (scanf("%d", &n) != EOF)
{
for (int i = 1; i <= n; ++i)
{
for (int j = 1; j <= i; ++j)
{
scanf("%d", &a[i][j]);
}
}
int ans;
for (int i = 1; i <= n; ++i)
b[n][i] = a[n][i];
for (int i = n-1; i > 0; --i)
{
for (int j = 1; j <= i; ++j)
{
b[i][j] = maxn(b[i+1][j], b[i+1][j+1]) + a[i][j];
}
}
ans = b[1][1];
printf("%d\n", ans);
}
return 0;
}