HDUOJ 1251 - 统计难题

54 篇文章 0 订阅
Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

Sample Input
  
  
banana band bee absolute acm ba b band abc
 

Sample Output
  
  
2 3 1 0
 


经典的字典树入门题。

创建节点,统计节点个数,就这样。

#include <cstdio>
#include <cstring>

char str[11];
struct node
{
    int counts;
    node* next[26];
    node ()
    {
        counts = 0;
        memset(next, 0, sizeof(next));
    }
};
node *root = new node();
node *p;

void insert_word()
{
    p = root;
    for (int i = 0; str[i] != '\0'; ++i)
    {
        int num = str[i] - 'a';
        if (p->next[num] == NULL){
            p->next[num] = new node();
        }
        p = p->next[num];
        p->counts++;
    }
}

int search_word()
{
    p = root;
    int i;
    for (i = 0; str[i] != '\0'; ++i)
    {
        int num = str[i] - 'a';
        if (p->next[num] == NULL)
            break;
        p = p->next[num];
    }
    if (str[i]) return 0;
    return p->counts;
}

int main()
{
    while (gets(str), *str)
        insert_word();
    while (gets(str) != NULL)
        printf("%d\n", search_word());
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值