HDUOJ1251 统计难题

Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

 

Sample Input
banana band bee absolute acm ba b band abc
 

 

Sample Output
2 3 1 0

 

字典树的问题,自己改的模板,鼓励一下,以后就用这个模板了!

#include <algorithm>
#include<vector>
#include<map>
#include<set>
#include<string>
#include<iostream>
using namespace std;
#define max(x,y) ((x)>(y)?(x):(y))

const int sonnum=26,base='a';  
struct Trie  
{  
    int num;
    bool leave;
    Trie *child[sonnum];
};  
Trie *NewTrie() 
{  
    Trie *temp = new Trie;  
    temp->num = 1;
 temp->leave = false;  
    for(int i=0;i<sonnum;i++)
  temp->child[i] = NULL;  
    return temp;  
}  
// insert a new word to Trie tree  
void Insert(Trie *node,char *s,int len)
{  
    for(int i=0;i<len;++i)  
    {  
        if(!node->child[s[i] - base])   
   node->child[s[i] - base] = NewTrie();  
        else
   node->child[s[i] - base]->num++;  
        node = node->child[s[i] - base];  
    }  
    node->leave = true;  
}  
// delete the whole tree  
void Delete(Trie *node)
{  
    if(node)  
    {  
        for(int i=0;i<sonnum;i++)
   if(node->child[i])
    Delete(node->child[i]);  
        delete node;
    }  
}  
//trie to find the current word  
Trie* Find(Trie *node,char *s,int len)
{  
    for(int i=0;i<len;i++)  
        if(node->child[s[i] - base])
   node=node->child[s[i] - base];  
        else
   return NULL;  
    return node;  
}

int main ()  
{  
 ifstream cin("test.txt");
 char str[12];
 Trie *root = new Trie();
 Trie *tmp;
 int i=0;
 while(cin.getline(str,12) && strcmp(str,""))
 {  
  Insert(root,str,strlen(str));
 }
 while(cin>>str)
 {
  tmp = Find(root,str,strlen(str));
  if(tmp)  
   cout<<tmp->num<<endl;
  else
   cout<<0<<endl;
 }
 return 0 ;  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值