HDU 5878 - I Count Two Three

54 篇文章 0 订阅
17 篇文章 0 订阅
Problem Description
I will show you the most popular board game in the Shanghai Ingress Resistance Team.
It all started several months ago.
We found out the home address of the enlightened agent Icount2three and decided to draw him out.
Millions of missiles were detonated, but some of them failed.

After the event, we analysed the laws of failed attacks.
It's interesting that the i-th attacks failed if and only if i can be rewritten as the form of 2a3b5c7d which a,b,c,d are non-negative integers.

At recent dinner parties, we call the integers with the form 2a3b5c7d "I Count Two Three Numbers".
A related board game with a given positive integer n from one agent, asks all participants the smallest "I Count Two Three Number" no smaller than n.


Input

The first line of input contains an integer t (1≤t≤500000), the number of test cases. t test cases follow. Each test case provides one integer n (1≤n≤109).


Output
For each test case, output one line with only one integer corresponding to the shortest "I Count Two Three Number" no smaller than n.


Sample Input


10
1
11
13
123
1234
12345
123456
1234567
12345678
123456789



Sample Output

1
12
14
125
1250
12348
123480
1234800
12348000

123480000


题意:给出一个 T,表示有 T 组输入数据,每组输入数据只有一个数字,找出形如 2^a * 3^b * 5^c 7^d 且比输入数字大的第一个数。

比赛的时候一开始认为 2a3b5c7d 之间是相乘的,但是看到discuss里说不是省略了称号,于是不知道怎么做了【跪】。其实就是打个表,每次找最近的即可。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const long long maxn = 1e9;
long long num[1000000 + 10];

long long Pow(int x, int n)
{
    long long ans = 1;
    for (int i = 1; i <= n; ++i)
        ans *= x;
    return ans;
}

int main()
{
    int cur = 0;
    long long temp;
    for (int i = 0; i <= 31; ++i)
    {
        for (int j = 0; j <= 19; ++j)
        {
            for (int k = 0; k <= 12; ++k)
            {
                for (int t = 0; t <= 11; ++t)
                {
                    temp = Pow(2, i) * Pow(3, j);
                    if (temp > maxn)
                        break;
                    temp *= Pow(5, k);
                    if (temp > maxn)
                        break;
                    temp *= Pow(7, t);
                    if (temp > maxn)
                        break;
                    num[cur++] = temp;
                }
            }
        }
    }
    sort(num, num + cur);

    int T;
    scanf("%d", &T);
    while (T--)
    {
        long long n;
        scanf("%lld", &n);
        int pos = lower_bound(num, num + cur, n) - num;
        pos;
        printf("%lld\n", num[pos]);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值