SDAU数论练习四-I(我也不知道题号是啥,没搜到)【打表预处理】

Discription
I will show you the most popular board game in the Shanghai Ingress Resistance Team.
It all started several months ago.
We found out the home address of the enlightened agent Icount2three and decided to draw him out.
Millions of missiles were detonated, but some of them failed.

After the event, we analysed the laws of failed attacks.
It’s interesting that the i-th attacks failed if and only if i can be rewritten as the form of 2^a *3^b *5^c * 7^dwhich a,b,c,d are non-negative integers.

At recent dinner parties, we call the integers with the form 2a3b5c7d “I Count Two Three Numbers”.
A related board game with a given positive integer n from one agent, asks all participants the smallest “I Count Two Three Number” no smaller than n.

Input
The first line of input contains an integer t (1≤t≤500000), the number of test cases. t test cases follow. Each test case provides one integer n (1≤n≤1e9).

Output
For each test case, output one line with only one integer corresponding to the shortest “I Count Two Three Number” no smaller than n.

Sample Input
10
1
11
13
123
1234
12345
123456
1234567
12345678
123456789
Sample Output
1
12
14
125
1250
12348
123480
1234800
12348000
123480000

题意
若一个数可以写成2^a *3^b *5^c * 7^d的形式,则称这个数满足条件。
有t个输入,每个输入一个数n,求满足>=n的最小的满足条件的数。

思路
预处理打表存在set里去重。
然后用lower_bound查找,不然会超时。
要注意四重循环应该循环到第几,不然容易漏。

AC代码

#include<bits/stdc++.h>
using namespace std;
#define LL long long
LL t,n;
set<LL>s;
set<LL>::iterator it;

void init()
{
    LL tmp=1;
    LL a=1,b=1,c=1,d=1;
    for(int i=1; i<=32; i++)
    {
        if(a>1e9)
            break;
        for(int j=1; j<=19; j++)
        {
            if(a*b>1e9)
                break;
            for(int k=1; k<=13; k++)
            {
                if(a*b*c>1e9)
                    break;
                for(int p=1; p<=11; p++)
                {
                    if(a*b*c*d>1e9)
                        break;
                    else
                        s.insert(a*b*c*d);
                    d*=7;
                }
                c*=5;
                d=1;
            }
            b*=3;
            c=1;
            d=1;
        }
        a*=2;
        b=1;
        c=1;
        d=1;
    }

}
int main()
{
    init();
    scanf("%lld",&t);
    while(t--)
    {
        scanf("%lld",&n);
         /*for(it=s.begin(); it!=s.end(); it++)
            if(*it>=n)
            {
                printf("%lld  ",*it);
                break;
            }*/
        it=s.lower_bound(n);
        printf("%lld\n",*it);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值