HDU 1532 - Drainage Ditches

54 篇文章 0 订阅

Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.



Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.



Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.



Sample Input
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10


Sample Output
50

题意:给出 n 条水道和 m 个顶点,每条水道给出起始点、终点和最大流量,请求出从 1 到 n 点中的最大流量。

初次接触最大网络流,并不是很熟。。。用了DFS和Ford-Fulkerson。

#include <cstdio>
#include <cstring>

int cru[200 + 5][200 + 5];
bool vis[200 + 5];
const int INF = 0x3f3f3f3f;

int DFS(int s, int t, int n, int low)
{
    int flow;
    if (s == t)
        return low;
    if (vis[s] == true)
        return 0;
    vis[s] = true;

    for (int i = 1; i <= n; ++i)
    {
        if ((cru[s][i] > 0) && (flow = DFS(i, t, n, low > cru[s][i] ? cru[s][i] : low)))
        {
            cru[s][i] -= flow;///水道已经占用了的流量
            cru[i][s] += flow;///反方向拥有的流量
            return flow;
        }
    }
    return 0;
}

int max_flow(int s, int t, int n)
{
    memset(vis, false, sizeof(vis));
    int maxflow = 0;
    int flow;

    while (flow = DFS(s, t, n, INF))
    {
        memset(vis, false, sizeof(vis));
        maxflow += flow;
    }
    return maxflow;
}

int main()
{
    int n, m;
    while (scanf("%d%d", &n, &m) != EOF)
    {
        memset(cru, 0, sizeof(cru));
        for (int i = 1; i <= n; ++i)
        {
            int from, to, v;
            scanf("%d%d%d", &from, &to, &v);
            cru[from][to] += v;
        }
        printf("%d\n", max_flow(1, m, m));
    }
    return 0;
}

/*
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10
*/


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值