解题报告 之 POJ1273 Drainage Ditches

解题报告 之 POJ1273 Drainage Ditches


Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50


题目大意:有n条水道,m个节点,每条水道的运水量不同,问最终从1最多运多少水到m?


分析:裸的最大流,最大流的相关讲述我看的是《挑战》感觉比较清晰。不过好像挑战的代码时间比较高,不知道什么原因。。可能是vector吧,于是乎在网上抄袭了一个大神的模板,并作为最终的模板。个人推荐平常没事敲Dinic练练手。比赛的时候抄上SAP模板保命即可。


建图也比较直接,不用拆点或者啥的。不过吐槽一下这个题n,m是反的,比较反人类。。。于是就直接上代码了。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<string>

using namespace std;

const int MAXN = 500;
const int MAXM = 80010;
const int INF = 0x3f3f3f3f;

struct Edge
{
	int to, next;
	int cap;
};

Edge edge[MAXM];

int cnt, src, des;
//cnt表示一共有几条边
int head[MAXN];
//head[i]表示节点i的第一条边的编号
int level[MAXN];

void addedge(int from, int to, int cap)
{
	edge[cnt].to = to;
	edge[cnt].cap = cap;
	edge[cnt].next = head[from];
	head[from] = cnt++;

	edge[cnt].to = from;
	edge[cnt].cap = 0;
	edge[cnt].next = head[to];
	head[to] = cnt++;
}

int bfs()
{
	queue<int> q;
	while (!q.empty())
		q.pop();
	memset(level, -1, sizeof(level));
	level[src] = 0; //源点的深度为0
	q.push(src);

	while (!q.empty())
	{
		int u = q.front();
		q.pop();
		for (int i = head[u]; i != -1; i = edge[i].next)
		{
			int v = edge[i].to;
			if (edge[i].cap > 0 && level[v] == -1) //该边未访问过且该边有流量
			{
				level[v] = level[u] + 1;
				q.push(v);
			}
		}
	}
	return level[des] != -1; //返回是否还存在连通路
}

int dfs(int u, int f)
{
	if (u == des)
		return f;
	int tem;
	for (int i = head[u]; i != -1; i = edge[i].next)
	{
		int v = edge[i].to;
		if (edge[i].cap > 0 && level[v] == level[u] + 1)
		{
			tem = dfs(v, min(f, edge[i].cap));
			if (tem > 0)
			{
				edge[i].cap -= tem;
				edge[i ^ 1].cap += tem; //更新边与反向边的流量
				return tem;
			}
		}
	}
	level[u] = -1; //表示已经走过该点
	return 0;
}

int Dinic()
{
	int ans = 0, tem;
	while (bfs())//如果还存在连通路
	{
		while (tem = dfs(src, INF)) //一直试图寻找增广路
		{
			ans += tem;
		}
	}
	return ans;
}


int main()
{
	int m, n;
	while (cin >> m >> n)
	{
		memset(head, -1, sizeof head);
		cnt = 0;
		for (int i = 0; i < m; i++)
		{
			int a, b, cost;
			cin >> a >> b >> cost;
			addedge(a, b, cost);
		}
		src = 1, des = n;
		cout << Dinic() << endl;
	}
	return 0;
}

用此模板注意head清-1,cnt=0,指定src和des的值,根据具体需要指定。

校赛和蓝桥都发挥的不顺手,,还把身份证耍掉了。。。好像死


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值