HDU 5914 - Triangle

54 篇文章 0 订阅


Problem Description
Mr. Frog has n sticks, whose lengths are 1,2, 3⋯n respectively. Wallice is a bad man, so he does not want Mr. Frog to form a triangle with three of the sticks here. He decides to steal some sticks! Output the minimal number of sticks he should steal so that Mr. Frog cannot form a triangle with
any three of the remaining sticks.


Input
The first line contains only one integer T (T≤20), which indicates the number of test cases.

For each test case, there is only one line describing the given integer n (1≤n≤20).


Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of sticks Wallice should steal.


Sample Input
3
4
5
6


Sample Output
Case #1: 1
Case #2: 1
Case #3: 2

 

题意:给出一个 n,分别有 1 - n 长度的木条各一条,问给出一个 n,求出去掉最少的木条数量,使剩下的木条中的任意 3 条均不能组成一个三角形。

让剩下的木条长度都是斐波那契中的数项即可,因为 n 只有20的大小,本渣渣纯手推的。。。

#include <cstdio>

int main()
{
    int ans[30] = {0, 0, 0, 0, 1, 1, 2, 3, 3, 4, 5, 6, 7, 7, 8, 9, 10, 11, 12, 13, 14};
    int T;
    scanf("%d", &T);
    for (int icase = 1; icase <= T; ++icase)
    {
        int n;
        scanf("%d", &n);
        printf("Case #%d: %d\n", icase, ans[n]);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值