C/C++经典程序训练3---模拟计算器 (sdut oj)


C/C++经典程序训练3---模拟计算器

Time Limit: 1000MS  Memory Limit: 4097KB


Problem Description
简单计算器模拟:输入两个整数和一个运算符,输出运算结果。

Input
第一行输入两个整数,用空格分开;
第二行输入一个运算符(+、-、*、/)。
所有运算均为整数运算,保证除数不包含0。

Output
输出对两个数运算后的结果。

Example Input
30 50
*

Example Output
1500

Hint
 
Author







参考代码


#include <stdio.h>
int main()
{
    int a,b;
    char y,x;
    scanf("%d%d%c",&a,&b,&y);  //字符型变量y吃掉输入过程中的换行
    scanf("%c",&x);
    if(x == '+') printf("%d",a + b);
    else if(x == '-') printf("%d",a - b);
    else if(x == '*') printf("%d",a * b);
    else if(x == '/') printf("%d",a / b);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值