POJ-1753(深搜DFS)

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 
Input
The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
Output
Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).
Sample Input
bwwb
bbwb
bwwb
bwww
Sample Output
4
/*

枚举所有状态,由于是4*4的棋盘所以最多2^16种状态,
也就是最多走16步,超过16步就无法将棋盘全变为一种颜色


*/





#include <iostream>  
#include<math.h>
#include<algorithm>
using namespace std;
int mp[6][6] = {0};
int flag = 0;
int step;
int dir[5][2] = { 0,1,1,0,0,-1,-1,0,0,0 };

bool juge()
{
	for (int i = 1; i <= 4; i++)
	{
		for (int j = 1; j <= 4; j++)
		{
			if (mp[i][j] != mp[1][1])
			{
				return false;
			}
		}
	}
	return true;
}


void fan(int row, int col)//翻转
{
	for (int i = 0; i < 5; i++)
	{
		int yy = row + dir[i][0];
		int xx = col + dir[i][1];
		if (xx >= 1 && xx <= 4 && yy >= 1 && yy <= 4)
		{
			mp[yy][xx] = !mp[yy][xx];
		}
	}
}


void dfs(int row, int col, int deep)//行,列,当前翻的次数
{
	if (deep == step)
	{
		flag = juge();
		return;
	}
	if (flag || row == 5)
		return;
	//翻棋
	fan(row, col);
	if (col < 4)
		dfs(row, col + 1, deep + 1);
	else
		dfs(row + 1, 1, deep + 1);
	//不符合条件翻转回来
	fan(row, col);
	if (col < 4)
		dfs(row, col + 1, deep);
	else
		dfs(row + 1, 1, deep);

	return;
}


int main()
{
	char k;
	for (int i = 1; i <= 4; i++)
	{
		for (int j = 1; j <= 4; j++)
		{
			cin >> k;
			if (k == 'b')
			{
				mp[i][j] = 1;
			}
			else
			{
				mp[i][j] = 0;
			}
		}
	}

	for (step = 0; step <= 16; step++)
	{
		dfs(1, 1, 0);
		if (flag)
			break;
	}

	if (flag)
		cout << step << endl;
	else
		cout << "Impossible" << endl;


	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值