POJ1753(DFS)

POJ1753(DFS)


Flip Game

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it’s black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:

  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

imgConsider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here “b” denotes pieces lying their black side up and “w” denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters “w” or “b” each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it’s impossible to achieve the goal, then write the word “Impossible” (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4
题意

给了你一个4*4的棋盘,棋盘上的每一个格子里都有一颗一面黑一面白的棋子,一开始给出你棋盘的初始状态,你可以给任何一个棋子翻面,但是如果你翻了某一个棋子,那他上下左右的棋子都要翻面。问你最少需要翻多少次才能让16枚棋子都为黑或都为白。

思路

对一个格子操作偶数次等于没有操作,操作奇数次等于操作一次,所以答案在0~16以及impossible之间。

从n=0开始枚举n次操作可能的组成情况,即操作哪几个格子,若某种组合能变图案为纯色则停止。

由于总组合数达到2^16,故枚举组合情况可以用dfs来进行回溯枚举。

代码
import java.util.Scanner;

public class FlipGame {
    int[][] checkerboard = new int[6][6];
    int count = 33;

    public static boolean check(int[][] checkerboard) {
        int result = 0;
        for (int i = 0; i < checkerboard.length; i++) {
            for (int j = 0; j < checkerboard[i].length; j++) {
                result = result + checkerboard[i][j];
            }
        }
        if (result == -16 || result == 16) {
            return true;
        } else {
            return false;
        }
    }

    public void flip(int s) {
        int x = s / 4 + 1;
        int y = s % 4 + 1;
        checkerboard[x][y] = -checkerboard[x][y];
        checkerboard[x - 1][y] = -checkerboard[x - 1][y];
        checkerboard[x][y - 1] = -checkerboard[x][y - 1];
        checkerboard[x + 1][y] = -checkerboard[x + 1][y];
        checkerboard[x][y + 1] = -checkerboard[x][y + 1];
    }


    public void dfs(int s,int b){//进行深搜.s代表当前的方格,b代表翻转的方格数
        if(check(this.checkerboard)){//如果是同一种颜色
            if (this.count > b){
                this.count = b;
                return;
            }
        }
        if(s >=16){
            return;
        }
        dfs(s+1,b);
        this.flip(s);
        dfs(s+1,b+1);
        this.flip(s);

    }

    public static void main(String[] args) {
        FlipGame fg = new FlipGame();
        Scanner sc = new Scanner(System.in);
        for (int i = 1; i < fg.checkerboard.length - 1; i++) {
            String str = sc.next();
            for (int j = 1; j < fg.checkerboard[i].length - 1; j++) {
                if (str.charAt(j - 1) == 'w') {
                    fg.checkerboard[i][j] = 1;
                } else {
                    fg.checkerboard[i][j] = -1;
                }
            }
        }
        fg.dfs(0,0);
        if(fg.count == 33){
            System.out.println("Impossible");
        }else {
            System.out.println(fg.count);
        }
        sc.close();
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值