HDU-2141(二分查找)

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X. 
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<= S<=1000. all the integers are 32-integers. 
Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print " NO". 
Sample Input
3 3 3 
1 2 3 
1 2 3 
1 2 3 
3 
1 
4 
10
Sample Output
Case 1: 
NO 
YES 
NO

/*
题解:
二分查找
做法是先将前两个数列相加产生sumAB数列,这个时候sumAB+c = k,
那么sumAB= k-c,每次询问k时,就用k减去c中的所有数,依次在sumAB数列中查找。
*/


#include <stdio.h>
#include <string.h>
#include<iostream>
#include <algorithm>
#include<math.h>
using namespace std;
int sumAB[250005];

int find(int l, int r, int ans)
{
	int mid = (l + r) / 2;
	
	if (sumAB[mid] == ans)
	{
		return 1;
	}
	else
	{
		if (l == r)
			return 0;
		if (sumAB[mid] > ans)
		{
			return find(l, mid, ans);
		}
		else
		{
			return find(mid + 1, r, ans);
		}
	}

}


int main()
{
	int l, m, n;
	int A[505], B[505], C[505];
	int cnt = 0;
	while (cin >> l >> m >> n)
	{
		for (int i = 0; i < l; i++)
		{
			scanf("%d", &A[i]);
		}
		for (int i = 0; i < m; i++)
		{
			scanf("%d", &B[i]);
		}
		for (int i = 0; i < n; i++)
		{
			scanf("%d", &C[i]);
		}
		int len = 0;
		for (int i = 0; i < l; i++)
		{
			for (int j = 0; j < m; j++)
			{
				sumAB[len++] = A[i] + B[j];
			}
		}
		sort(sumAB, sumAB + len);
		int flag=0;
		int tt;
		cin >> tt;
		int tempcnt = 0;
		while (tt--)
		{
			
			int k;
			cin >> k;
			if (tempcnt == 0)
			{
				tempcnt = 1;
				printf("Case %d:\n", ++cnt);
			}
			 flag = 0;
			for (int i = 0; i < n&&flag == 0; i++)
			{
				flag = find(0, len - 1, k-C[i]);
			}
			if (flag == 0)
			{
				cout << "NO" << endl;
			}
			else
			{
				cout << "YES" << endl;
			}

		}
	}

	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值