HDU-2141

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X. 
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers. 
Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO". 
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output
Case 1:
NO
YES
NO
这道题就是首先想到会将他们三个数表的所有情况列出来,放进一个数组里,但是这样去做的时候,就会超
出限制,也就是会出现memory limited exceed,再去看题目的要求,发现这里的每一个数表的大小是500,
三个数表的大小相乘。就会超过10000kb的限制,但是如果是两个数表的大小乘起来的话,就不会超过限制,
所以可以想到,先将两个数表的和算出来,然后再根据答案,在剩下的一个数表中用二分法找答案,由于二
分法是需要数表有序的,就可以用头文件algorithm中的sort,当然这就是具体的解体细节了,然后将思路实
这样就可以ac了
#include<iostream>
#include<algorithm>
using namespace std;

int find_need(int a[],int s,int need)
{
    int low = 0;
    int high = s-1;
    while(low<high)
    {
        int mid = (low+high)/2;
        if(a[low]==need||a[high]==need||a[mid]==need) return true;
        else if(a[mid]>need) high = mid-1;
        else low = mid+1;
    }
    return false;
}

int main()
{
    int times = 0;
    int anum,bnum,cnum;
    while(cin>>anum>>bnum>>cnum)
    {
        times++;
        cout<<"Case "<<times<<":"<<endl;
        int ava[anum],bva[bnum],cva[cnum];
        for(int i = 0;i<anum;i++)
            cin>>ava[i];
        for(int i = 0;i<bnum;i++)
            cin>>bva[i];
        for(int i = 0;i<cnum;i++)
            cin>>cva[i];
        int sum[bnum*cnum];
        int help = 0;
        for(int i = 0;i<bnum;i++)
        {
            for(int j = 0;j<cnum;j++)
            {
                sum[help] = bva[i]+cva[j];
                help++;
            }
        }
        sort(sum,sum+bnum*cnum);
        int xnum;
        cin>>xnum;
        int yes[xnum];
        int xva[xnum];
        for(int i = 0;i<xnum;i++)
        {
            yes[i] = 0;
            cin>>xva[i];
            for(int j = 0;j<anum;j++)
            {
                if(find_need(sum,bnum*cnum,xva[i]-ava[j]))
                {
                    yes[i] = 1;
                    break;
                }
            }
            if(yes[i]==1) cout<<"YES"<<endl;
            else cout<<"NO"<<endl;
        }

    }
}


 
 
 
 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值