Several coins are placed in cells of an n×m board. A robot, located in the upper left cell of the board, needs to collect as many of the coins as possible and bring them to the bottom right cell. On each step, the robot can move either one cell to the right or one cell down from its current location.
输入
The fist line is n,m, which 1< = n,m <= 1000. Then, have n row and m col, which has a coin in cell, the cell number is 1, otherwise is 0.
输出
The max number Coin-collecting by robot.
样例输入
5 6 0 0 0 0 1 0 0 1 0 1 0 0 0 0 0 1 0 1 0 0 1 0 0 1 1 0 0 0 1 0
样例输出
5
思路:动态规划。
dp【i】【j】表示走到(i,j)这个点所能获得的最大coin数。
转移方程为:
mp[i][j] = max(mp[i - 1][j], mp[i][j - 1]);
#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#include<queue>
#include<iostream>
#include<string.h>
using namespace std;
int mp[1005][1005];
//oj1132
int main()
{
int n, m;
while (cin >> n >> m) {
for (int i = 0;i < n;i++) {
for (int j = 0;j < m;j++) {
scanf("%d", &mp[i][j]);
}
}
for (int i = 1;i < n;i++)
{
if (mp[i][0] == 1) {
mp[i][0] = mp[i - 1][0]+1;
}
else {
mp[i][0] = mp[i - 1][0];
}
}
for (int i = 1;i < m;i++) {
if (mp[0][i] == 1) {
mp[0][i] = mp[0][i - 1] + 1;
}
else {
mp[0][i] = mp[0][i - 1];
}
}
for (int i = 1;i < n;i++) {
for (int j = 1;j < m;j++) {
if(mp[i][j])
mp[i][j] = max(mp[i - 1][j], mp[i][j - 1])+1;
else {
mp[i][j] = max(mp[i - 1][j], mp[i][j - 1]);
}
}
}
int ans = mp[n - 1][m - 1];
cout << ans <<"\r\n";
}
return 0;
}