SWUST OJ 1132: Coin-collecting by robot

题目描述

Several coins are placed in cells of an n×m board. A robot, located in the upper left cell of the board, needs to collect as many of the coins as possible and bring them to the bottom right cell. On each step, the robot can move either one cell to the right or one cell down from its current location.

输入

The fist line is n,m, which 1< = n,m <= 1000.
Then, have n row and m col, which has a coin in cell, the cell number is 1, otherwise is 0.

输出

The max number Coin-collecting by robot.

样例输入

5 6
0 0 0 0 1 0 
0 1 0 1 0 0 
0 0 0 1 0 1 
0 0 1 0 0 1 
1 0 0 0 1 0

样例输出

5
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
///计算最大值
int Max(int a,int b)
{
    return a>b?a:b;
}
int arr[1001][1001];
void Maxvalue(int n,int m)
{
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=m;j++)
            arr[i][j]=Max(arr[i-1][j],arr[i][j-1])+arr[i][j];

    }
}
int main()
{

    memset(arr,0,sizeof(arr));
    int n,m;
    cin>>n>>m;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<m;j++)
        {
           scanf("%d", &arr[i][j]);
        }
    }
    Maxvalue(n,m);
    printf("%d\n",arr[n][m]);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值