【JAVA】 PAT 乙级 1081 检查密码

【JAVA】 PAT 乙级 1081 检查密码


题目链接
本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。

输入格式:
输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

输出格式:
对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

如果密码合法,输出Your password is wan mei.;
如果密码太短,不论合法与否,都输出Your password is tai duan le.;
如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.;
如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.;
如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.。

输入样例:

5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例:

Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

这道题不难,按照题目要求一个个条件判断就可以了,而且要求也不复杂,长度至少为6,既要有数字也要有字母,其他的字符除了小数点一律不能出现

完整AC代码

import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.io.OutputStreamWriter;
import java.io.PrintWriter;

public class Main {
	public static void main(String[] args) throws Exception {
		BufferedReader bf = new BufferedReader(new InputStreamReader(System.in));
		PrintWriter out = new PrintWriter(new OutputStreamWriter(System.out));
		int n = sti(bf.readLine());
		for (int i = 0; i < n; i++) {
			String s = bf.readLine();
			if (checklen(s)) {
				if (checkilc(s, out)) {
					out.println("Your password is wan mei.");
				}
			}else{
				out.println("Your password is tai duan le.");
			}
		}
		out.flush();
	}

	private static boolean checkilc(String a, PrintWriter out) {
		char[] s = a.toCharArray();
		int countzm = 0;
		int countsz = 0;
		for (int i = 0; i < s.length; i++) {
			if (s[i] == '.') {
				continue;
			} else if ((s[i] >= 'a' && s[i] <= 'z')
					|| (s[i] >= 'A' && s[i] <= 'Z')) {
				countzm++;

			} else if (s[i] >= '0' && s[i] <= '9') {
				countsz++;

			} else {
				out.println("Your password is tai luan le.");
				return false;
			}
		}
		if (countzm == 0) {
			out.println("Your password needs zi mu.");
			return false;
		}
		if (countsz == 0) {
			out.println("Your password needs shu zi.");
			return false;

		}
		return true;
	}

	static int sti(String a) {
		return Integer.parseInt(a);
	}

	static boolean checklen(String a) {
		return a.length() >= 6;
	}

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值