E - The order of a Tree HDU - 3999

As we know,the shape of a binary search tree is greatly related to the order of keys we insert. To be precisely: 
1.  insert a key k to a empty tree, then the tree become a tree with 
only one node; 
2.  insert a key k to a nonempty tree, if k is less than the root ,insert 
it to the left sub-tree;else insert k to the right sub-tree. 
We call the order of keys we insert “the order of a tree”,your task is,given a oder of a tree, find the order of a tree with the least lexicographic order that generate the same tree.Two trees are the same if and only if they have the same shape. 

Input

There are multiple test cases in an input file. The first line of each testcase is an integer n(n <= 100,000),represent the number of nodes.The second line has n intergers,k1 to kn,represent the order of a tree.To make if more simple, k1 to kn is a sequence of 1 to n. 

Output

One line with n intergers, which are the order of a tree that generate the same tree with the least lexicographic. 

Sample Input

4

1 3 4 2

Sample Output

1 3 2 4

题目的意思是给你一个搜索二叉树的任意序列求最小字典序的一个序列

解题思路就是构建一个搜索二叉树然后求它的前序遍历即可。

前序遍历就是先根节点 -->左节点 -->右节点 ,因为   根>左 。,而右 >根所以这是最小的字典序

代码:

#include<stdio.h>
#include<stdlib.h>
int k;
typedef struct note
{
    int data;
    struct note *left;
    struct note *right;
} Note;
typedef struct
{
    Note *root;
} Tree;
void insert(Tree *tree,int value)  //构建搜索二叉树
{
    Note *note = malloc(sizeof(Note));
    note ->data =value;
    note ->left =NULL;
    note ->right=NULL;
    if(tree->root==NULL)
    {
        tree -> root=note;
    }
    else
    {
        Note *temp= tree ->root;
        while(temp != NULL)
        {
            if(value<temp -> data)
            {
                if(temp->left==NULL)
                {
                    temp->left=note;
                    return;
                }
                else
                {
                    temp=temp ->left;
                }
            }
            if(value>temp->data)
            {
                if(temp->right==NULL)
                {
                    temp->right=note;
                    return;
                }
                else
                {
                    temp=temp->right;
                }
            }
        }
    }
}
void perorder(Note *note)     //前序遍历
{
    if(note !=NULL)
    {   if(k==0)
        printf("%d",note -> data);
        else
        printf(" %d",note -> data);   //前序遍历
        k++;
        perorder(note -> left);
        perorder(note -> right);
    }

}
int main()
{
    int n;
    int b[110000];
    while(~scanf("%d",&n))
    {
        Tree tree;
        tree.root=NULL;
        int a,i;
        for(i=0; i<n; i++)
        {
            scanf("%d",&a);
            insert(&tree,a); //构建二叉树
        }
        k=0;
        perorder(tree.root); //前序遍历
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值