HDU3999 The order of a Tree(构建二叉搜索树模板指针)

As we know,the shape of a binary search tree is greatly related to the order of keys we insert. To be precisely:
1. insert a key k to a empty tree, then the tree become a tree with
only one node;
2. insert a key k to a nonempty tree, if k is less than the root ,insert
it to the left sub-tree;else insert k to the right sub-tree.
We call the order of keys we insert “the order of a tree”,your task is,given a oder of a tree, find the order of a tree with the least lexicographic order that generate the same tree.Two trees are the same if and only if they have the same shape.
Input
There are multiple test cases in an input file. The first line of each testcase is an integer n(n <= 100,000),represent the number of nodes.The second line has n intergers,k1 to kn,represent the order of a tree.To make if more simple, k1 to kn is a sequence of 1 to n.
Output
One line with n intergers, which are the order of a tree that generate the same tree with the least lexicographic.
Sample Input
4

1 3 4 2
Sample Output
1 3 2 4

题意:输入数据构建一个二叉搜索树,先序输出

解题思路:
用指针构建搜索二叉树,指针应更加深刻的学习。

比构建一般二叉树多个判断。

AC代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;

int n,flag;

typedef struct node
{
    int data;
    node *lchild,*rchild;//左子结点、右子结点 
}BiTreeNode,*BiTree;

void insert(BiTree &T,int x)//递归插入 
{
    if(T==NULL)//如果这个结点没有值 
    {
        T=new BiTreeNode;//申请空间 
        T->data=x;//将x赋给这个结点 
        T->lchild=T->rchild=NULL;//初始化左右子树没有值 
        return;//处理下一个数据 
    }
    if(x<T->data)//如果x小于根的值 (比构建一般二叉树多的一句话)
        insert(T->lchild,x);//把x插入左子树 
    else//如果x大于根的值 (比构建一般二叉树多的一句话)
        insert(T->rchild,x);//把x插入右子树 
}

void preOrder(BiTree &T)//先序遍历输出二叉搜索树 
{
    if(T)//如果根结点有值则输出这个子树 
    {
        if(flag)
            printf(" ");
        printf("%d",T->data);//输出根结点的值 
        flag=1;
        preOrder(T->lchild);//输出左子结点的值 
        preOrder(T->rchild);//输出右子结点的值 
    }
}

int main()
{
    while(~scanf("%d",&n))
    {
        int x;
        BiTree T=NULL;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&x);//输入一个数处理一个数 
            insert(T,x);//将输入的数插入树 
        }
        flag=0;//格式输出 
        preOrder(T);//前序遍历输出 
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值