BZOJ 1734: [Usaco2005 feb]Aggressive cows 愤怒的牛

原题链接

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

农夫 John 建造了一座很长的畜栏,它包括NN (2 <= N <= 100,000)个隔间,这些小隔间依次编号为x1,...,xN (0 <= xi <= 1,000,000,000). 但是,John的C (2 <= C <= N)头牛们并不喜欢这种布局,而且几头牛放在一个隔间里,他们就要发生争斗。为了不让牛互相伤害。John决定自己给牛分配隔间,使任意两头牛之间的最小距离尽可能的大,那么,这个最大的最小距离是什么呢

Input

* Line 1: Two space-separated integers: N and C * Lines 2..N+1: Line i+1 contains an integer stall location, xi

第一行:空格分隔的两个整数N和C

第二行---第N+1行:i+1行指出了xi的位置

Output

* Line 1: One integer: the largest minimum distance

第一行:一个整数,最大的最小值

Sample Input

5 3
1
2
8
4
9
 

Sample Output

3

把牛放在1,4,8这样最小距离是3

 

这题怎么感觉和跳石头神似啊?

看到最大值最小果断二分,二分之后贪心判断正确性。

先把牛棚排序,上限值就随便设置个x[n]-x[1],下限显然是1。

既然是贪心的话,第一只牛就直接丢在第一个牛棚里,然后O(n)扫一遍剩下的牛棚,如果和上一头牛所在牛棚距离超过了二分的这个答案,就把这头牛放进去。最后判断一共能放几头牛。显然放的牛如果多了说明距离设置小了,放的牛少了说明距离设置大了。

 

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#define LL long long
using namespace std;
int n,c;
int a[100005],ck[100005];
inline bool check(int x)
{
    int cnt=1;
    ck[1]=a[1];
    for(register int i=2;i<=n;++i)
        if(a[i]-ck[cnt]>=x)
            ck[++cnt]=a[i];
    if(cnt>=c) return 0;
    return 1;
}
int main()
{
    cin>>n>>c;
    for(register int i=1;i<=n;++i)
        cin>>a[i];
    sort(a+1,a+n+1);
    int l=1,r=a[n]-a[1];
    while(l+1<r)
    {
        int mid=(l+r)>>1;
        if(check(mid)) r=mid;
        else l=mid;
    }
    cout<<l<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值