HDU - 2069 Coin Change

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2069

Problem Description
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.

Input
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.

Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input
11
26

Sample Output
4
13

大意:有5种硬币,面值为1分,5分,10分,25分,50分。输入一个数s,输出组合方案数,s<=250,硬币使用数<=100。

分析:因为有硬币使用的数目作为限制,则可以考虑二维的dp数组,dp[i][j],i表示总面值,j表示使用的硬币数量。将dp[0][0]初始化为1,dp[1][1]表示总面值为1,选取硬币数为1的方案数,则dp[1][1]=dp[1][1]+dp[1-1][1-1],类似的有dp[i][j]+=dp[i-type[k]]j-1,保证每一种面值都有选过。

代码如下:

#include<cstdio>
using namespace std;
const int type[] = { 1,5,10,25,50 };
int dp[251][101] = { 1 }, ans[251];
int main(void) {
	for (int i = 0; i < 5; i++)
		for (int k = 1; k <= 100; k++)
			for (int j = type[i]; j <= 250; j++)
				dp[j][k] += dp[j - type[i]][k - 1];
	for (int i = 0; i <= 250; i++)
		for (int j = 0; j <= 100; j++)
			ans[i] += dp[i][j];
	int x;
	while (~scanf("%d", &x))
		printf("%d\n", ans[x]);
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

JILIN.

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值