Coin Change UVA - 674(完全背包 dp)

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make
changes with these coins for a given amount of money.
For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent
coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins.
So there are four ways of making changes for 11 cents with the above coins. Note that we count that
there is one way of making change for zero cent.
Write a program to find the total number of different ways of making changes for any amount of
money in cents. Your program should be able to handle up to 7489 cents.
Input
The input file contains any number of lines, each one consisting of a number for the amount of money
in cents.
Output
For each input line, output a line containing the number of different ways of making changes with the
above 5 types of coins.
Sample Input
11
26
Sample Output
4
13

思路:
第一感觉就是完全背包,要是搁以前我就用dfs加记忆化搜索写了,不知道会不会超时,既然学了背包,就用背包写吧;实际上还是dfs的思想,比如要求55的组成方案数,,必须要知道55-1=54的方案数 和 55-5=50的方案数,和50-10=45的方案数和55-25=30的方案数和55-50=5的方案数,所以dp以此类推,每次更新dp;

AC代码:

一维数组实现
#include <bits/stdc++.h>

using namespace std;
int v[6];
int dp[100001];
int main()
{
    int n;
    v[0]=1,v[1]=5,v[2]=10,v[3]=25,v[4]=50;
    while(~scanf("%d",&n))
    {
        memset(dp,0,sizeof dp);
        dp[0]=1;
        for(int i=0;i<5;i++)
            for(int j=v[i];j<=n;j++)
                dp[j]=dp[j-v[i]]+dp[j];
        cout <<dp[n]<<endl;

    }
    return 0;
}
  • 0
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值