Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4 10 20
Sample Output
5 42 627
这道题是求整数拆分的方案数,可以先用母函数预处理120以内所有数拆分的方案数,再直接输出,下面是程序:
#include<stdio.h>
#include<iostream>
#define ll unsigned long long
using namespace std;
const int N=125;
ll s[N],a[N];
void out(ll n){
if(n>9){
out(n/10);
}
putchar(n%10+'0');
}
int main(){
int n,i,j,k;
for(i=0;i<=N;++i){
s[i]=1;
a[i]=0;
}
for(i=2;i<=N;++i){
for(j=0;j<=N;++j){
for(k=0;j+k<=N;k+=i){
a[j+k]+=s[j];
}
}
for(j=0;j<=N;++j){
s[j]=a[j];
a[j]=0;
}
}
while(~scanf("%d",&n)){
out(s[n]);
putchar('\n');
}
return 0;
}