Description
While exploring his many farms, Farmer John hasdiscovered a number of amazing wormholes. A wormhole is very peculiar becauseit is a one-way path that delivers you to its destination at a time that isBEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N≤ 500) fields conveniently numbered 1..N,M (1 ≤ M ≤ 2500)paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to dothe following: start at some field, travel through some paths and wormholes,and return to the starting field a time before his initial departure. Perhapshe will be able to meet himself :) .
To help FJ find out whether this is possible or not,he will supply you with complete maps toF (1 ≤ F ≤ 5) of hisfarms. No paths will take longer than 10,000 seconds to travel and no wormholecan bring FJ back in time by more than 10,000 seconds.
Input
Line 1: A single integer, F. F farm descriptionsfollow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) thatdescribe, respectively: a bidirectional path between S and E that requires Tseconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) thatdescribe, respectively: A one way path from S to E that also moves the travelerback T seconds.
Output
Lines 1..F: For each farm, output "YES" ifFJ can achieve his goal, otherwise output "NO" (do not include thequotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1,arriving back at his starting location 1 second before he leaves. He couldstart from anywhere on the cycle to accomplish this.
这道题本质上就是判断一个图中是否存在负环,所以只要跑一遍SPFA,判断是否有节点入队达到N次,如果达到N次,则有负环,下面是代码:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<iostream>
#include<queue>
using namespace std;
int vis[505],dis[505];
struct line{
int v,w;
line *next;
};
line *head[505];
line *make(){
return (line *)(malloc(sizeof(line)));
}
void add(int u,int v,int w){
line *x=make();
x->v=v;
x->w=w;
x->next=head[u];
head[u]=x;
}
void work(){
memset(dis,0x7f,sizeof(dis));
memset(vis,0,sizeof(vis));
memset(head,0,sizeof(head));
queue<int>dl;
int n,m,w,i,u,v,t;
scanf("%d%d%d",&n,&m,&w);
for(i=0;i<m;i++){
scanf("%d%d%d",&u,&v,&t);
add(u,v,t);
add(v,u,t);
}
for(i=0;i<w;i++){
scanf("%d%d%d",&u,&v,&t);
add(u,v,-1*t);
}
dl.push(1);
dis[1]=0;
while(!dl.empty()){
int x=dl.front();
dl.pop();
if(vis[x]>=n){
printf("YES\n");
return;
}
for(line *now=head[x];now;now=now->next){
if(dis[now->v]>dis[x]+now->w){
dis[now->v]=dis[x]+now->w;
dl.push(now->v);
vis[now->v]++;
}
}
}
for(i=1;i<=n;i++){
line *now=head[i],*x;
while(now){
x=now;
now=now->next;
free(x);
}
}
printf("NO\n");
}
int main(){
int t;
scanf("%d",&t);
while(t--){
work();
}
return 0;
}