【poj 2481】 Cows

Description

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good. 

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E]. 

But some cows are strong and some are weak. Given two cows: cowi and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cowi is stronger than cowj. 

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases. 
For each test case, the first line is an integer N (1 <= N <= 105), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 105) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge. 

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi. 

Sample Input

3
1 2
0 3
3 4
0

Sample Output

1 0 0

Hint

Huge input and output,scanf and printf is recommended.

这道题题意是说每头牛有一个区间,问每头牛的区间会被几头牛的区间包含,按左端点或右端点排序后树状数组维护即可,下面是程序:

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
#define lowbit(n) n&(-n)
using namespace std;
const int N=100005;
struct cow{
	int l,r,ans,x;
	bool operator <(const cow &p)const{
		return r==p.r?l<p.l:r>p.r;
	}
	bool operator ==(const cow &p)const{
		return l==p.l&&r==p.r;
	}
}a[N];
struct tree{
	int c[N],n;
	void build(int &l){
		n=l;
		memset(c,0,sizeof(c));
	}
	void add(int x){
		while(x<=n){
			++c[x];
			x+=lowbit(x);
		}
	}
	int ask(int x){
		int s=0;
		while(x){
			s+=c[x];
			x-=lowbit(x);
		}
		return s;
	}
}t;
bool cmp(cow a,cow b){
	return a.x<b.x;
}
int main(){
	int n,i;
	do{
		scanf("%d",&n);
		if(!n){
			break;
		}
		for(i=1;i<=n;i++){
			scanf("%d%d",&a[i].l,&a[i].r);
			++a[i].l,++a[i].r;
			a[i].x=i;
		}
		sort(a+1,a+n+1);
		t.build(n);
		for(i=1;i<=n;i++){
			if(a[i]==a[i-1]){
				a[i].ans=a[i-1].ans;
			}
			else{
				a[i].ans=t.ask(a[i].l);
			}
			t.add(a[i].l);
		}
		sort(a+1,a+n+1,cmp);
		for(i=1;i<n;i++){
			printf("%d ",a[i].ans);
		}
		printf("%d\n",a[i].ans);
	}while(n);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值